FixVolumeOnboot - feste lautstärke beim booten

  • würde sowas auch für volume aus standby irgwndwie gehen ?
    das suche ich noch...


  • Ohh noch einer der bei der Feuerwehr arbeitet! Oder im RD?

    Cobra-112 :em_germany:


    DM 920UHD
    OE2.5 Exp * GP3.3
    HD-Plus und SKY Full

  • Quote

    würde sowas auch für volume aus standby irgwndwie gehen ? das suche ich noch...


    diddsen


    machbar ist das ;) hat mich bisschen lesearbeit gekostet.
    ich kann sowas ja garnicht und ist deswegen leider nur Quick&Dirty
    Aber es tut was es soll


    lautstärke bitte in dem script anpassen
    du kopierst das script nach /usr/script
    rechte auf 755
    dann fügst du 3 zeilen in die /usr/lib/enigma2/python/Screens/Standby.py ein
    genau NACH dem print "leave standby"
    die richtigen einrückungen nicht vergessen


    Code
    import os
    if os.path.exists("/usr/script/e2_leave_standby.sh"):
    os.system("/usr/script/e2_leave_standby.sh &")
  • wow... danke :-)
    nur schade das nach jedem update wieder neu gemacht werden muss

  • was mache ich bitte nur falsch ? Immer wenn ich das script ausführen will sei es über telnet oder über den FileBrowser bekomme ich fogenden Meldung:


    -sh: /fixbootvolume.sh: not found


    zudem hab ich keine Ordner unter /usr der sich /sript nennt.


    Was muss ich denn noch installieren oder wo liegt der Fehler das es nicht will ?


    Danke schon mal für Eure Hilfe


    Gruß Homerius

    Baust 'nen Turbo in den Diesel, läuft der Diesel wie ein Weasel ...

  • Wenn Du den Ordner "script" nicht hast (musst ihn dann halt selbst anlegen), wo hast Du das Script denn hinkopiert?

  • Ok ja das hab ich ja auch schon gemacht und soeben nochmal gemacht


    Habe den Ordner script wie das File mit den Rechten 755 gesetzt. Dann ins Telnet rein und dann kommt immer die selbe Meldung und zwar diese hier:


    root@dm800:~# /usr/script/fixbootvolume.sh
    -sh: /usr/script/fixbootvolume.sh: not found


    Das File hab ich von hier geladen und habe nur von 80 auf 100 das Volumen verändert. Benutze Smultron als Editor


    bin über jeden Tipp oder Rat dankbar


    Gruß Homerius

    Baust 'nen Turbo in den Diesel, läuft der Diesel wie ein Weasel ...

    Edited once, last by Homerius ().

  • wenn du dcc hast, dann geh mal per ftp nach


    /usr/script


    ist das script dort vorhanden?


    oder über telnet


    cd /usr/script
    ls


    dann solltest du den inhalt sehen

    gruß Friday :499:


    >>> FixBootVolume <<<


    «Nimm Friday, der macht´s auch mit der Nachbarin.» :D

  • Ja das ist da und ich kann es sehen hoffe es macht nix das ich Filezilla nutze :)


    Komisch ist das ich mal auf 100 gestellt habe und wenn ich nun neu boote es immer wieder auf 100 ist ist das script nun doch am laufen ? oder ist was am Image geändert worde. weil mußte gestern leider mal neu flashen und danach wollte ich eben die Datei wieder installieren wie damals auch und da ging es wie in deiner Anleitung

    Baust 'nen Turbo in den Diesel, läuft der Diesel wie ein Weasel ...

  • eine frage:
    läuft das denn mit automatic volume adjust zusammen?


    beispiel:
    ich habe ava so eingestellt das es 25% die lautstärke erhöht bei ac3.
    ich würde nun gerne die grundlautstärke auf 75% einstellen, so das bei ac3 100% und bei mpeg 75% lautstärke rauskommen.


    was passiert nun wenn das obige script mit 75% und dazu das plugin ava verwendet werden wenn der startchannel ein ac3 sender ist?
    wird der dann auch 100% eingestellt und die mpeg channel auf 75%?
    oder wird der auf 75% eingestellt und die mpeg sender stehen auf 50%?


    letzteres wäre schlecht, da die gesamtlautstärke dann ja von der gerade auf dem startchannel ausgestrahlten programm abhängt.


    wäre es eventuell sinnvoll das irgendwie mit dem "automatic volume adjust" plugin in eines zusammenzupacken?

  • ich weiß nicht wie das "automatic volume adjust" arbeitet


    gib mir mal nen link dazu


    mein script trägt ja nur eine feste lautstärke beim booten ein von 0-100

    gruß Friday :499:


    >>> FixBootVolume <<<


    «Nimm Friday, der macht´s auch mit der Nachbarin.» :D

  • ok, aber mein script setzt ja nur die lautstärke beim starten der box
    was danach durch plugins nachträglich geändert wird hat auf mein script kein einfluss

    Quote

    Wenn Ihr auf einem nicht AC3-Ton-Kanal steht, und die Lautstärke ist auf 100, so wird natürlich beim Umschalten auf einen AC3-Kanal nichts mehr geändert...springt man wieder zurück, ist der Lautstärkenwert immer noch 100...


    wenn du jetz im script 100 einstellst kann natürlich nichts mehr erhöht werden


    teste es doch einfach mal ;)

    gruß Friday :499:


    >>> FixBootVolume <<<


    «Nimm Friday, der macht´s auch mit der Nachbarin.» :D

  • ja, werd ich dann denke ich wohl demnächst mal tun :-)
    ich denke es wird dann die reihenfolge wichtig sein.
    denn wenn zuerst "autovolume" zuschlägt und dann dein script wäre das ergebnis ja das falsche :-)
    ebenso wäre die frage wichtig:
    erkennt autovolume das booten der box auf dem startupchannel als zap auf den channel? oder zieht das plugin erst beim wegzappen?


    eventuell schau ich das mal am wochenende an und versuch es zu verstehen :-)

  • Und meine Fehler weiß da einer mehr was zu wieso das immer kommt wenn ich es ausführen will ?

    Baust 'nen Turbo in den Diesel, läuft der Diesel wie ein Weasel ...

  • ich versteh nicht ganz was nicht geht. es startet doch jetzt mit 100


    erzähl nochmal ganz genau was du gemacht hast, oder was nicht geht

    gruß Friday :499:


    >>> FixBootVolume <<<


    «Nimm Friday, der macht´s auch mit der Nachbarin.» :D

    Edited once, last by friday13 ().

  • eine frage:


    bei mir funktioniert das plugin unter OE2 nicht mehr,


    wie kann ich das anpassen?

  • das ist nur ein script (kein plugin)


    und da ich 2.0 noch nicht laufen habe, kann ich nicht viel helfen


    was passiert denn, oder passiert nicht?

    gruß Friday :499:


    >>> FixBootVolume <<<


    «Nimm Friday, der macht´s auch mit der Nachbarin.» :D

  • in enigma settings wird die lautstärke nicht geändert,


    es wird eine bootup datei angelegt,
    aber in oe2 gibt es normal keine bootup datei in etc/init.d,
    vielleicht hängt das damit zusammen?

    Edited once, last by budyy ().

  • ja, und selbst wenn sie existiert würde sie nicht mehr ausgeführt.

    Edited once, last by gutemine ().