Mountie für GP2 >=4.2 mit udev und device Labeling !

  • ich habe mountie deinstalliert, den softlink gelöscht und rebootet.
    danach montie wieder installiert nun wurde die 2. Partition der CF als /media/ba gemountet.
    der symlink in root lautet bei mir auch ba.
    kA ob das vorher BA war und durch mein gefummelts nun zu ba wurde.

  • na ja mach dir im Moment keinen stress - die BA labels werde vom BA derzeit gar nicht verwendet, insofern ist es kein großes problem.


    Und FAT label werden von Mountie immer vo ngross auf Kleinbuchstabeln konvertiert (weil FAT label immer gross sind und du sonst nicht auf /media/usb mounten könntest) - insofern ist der WW link wahrscheinlich gar nicht nötig


    LG
    gutemine

    Edited once, last by gutemine ().

  • jo ok, der tatsächliche mount der 1. CF Partition ist hier ww (wohl wegen FAT) in mountie ists WW.
    zu ba oder BA, ich weiss ja nicht welche Auswirkungen das auf barryallen hat, deshalb mein Stress ;)

  • Mountie zeigt immer den echten label, schon um verwirrung zu vermeiden mit dem was du am PC siehst, nur werden bei FAT wo ja nur Grossbuchstaben gehen (stammt halt aus DOS zeiten) diese einfach auf klein umgemapped für den mountoint - macht im Linux mehr Sinn und sonst könntest du einen FAT stick nicht auf /media/usb mounten lassen.


    Das war eines der Wünsche/Ergebnisse aus dem ursprünglichen Mountie Thread - Mountie4GP2 ist davon ja nur ein Ableger - deswegen funktioniert er aber auch schon halbwegs stabil.


    Der Unterschied zum echten Mountie ist das der kein zusätzliches Filesystem/moutndameon wie autofs/udev,.. benötigt sondern alles im python macht - wie es eigentlich am elegantesten wäre - aber das ist Geschmacksache.


    PS: Für ext3 oder ntfs kann man beim Label gross/klein und jede beliebige Mischung nehmen - falls es Sinn/Laune macht.


    LG
    gutemine

    Edited once, last by gutemine ().

  • Noch eine Antwort zu einer Frage aus einem anderen Thread - was wäre wenn Mountie wenn er auf einem device ein swapfile findet dieses automatisch benutzt statt es mühsam im BP zu enabeln ?


    Sind auch nur 3 codezeilen mehr.


    Wenn es wer testen will einfach das udev_mountie.sh aus dem Anhang per FTP über das udev_mount.sh (nicht das udev_mountie.sh) in /usr/script drüber kopieren.


    Wenn dann auf einem device nach dem mounten ein file mit namen swapfile gefunden wird dann wird einfach drauf geswapped.


    Nur abstecken dieses devices im laufenden betrieb wird dann nicht gut gehen, und es erinnert mich auch daran das ich dem suspend im mountie noch ein swapoff -a spendieren muss.


    Bitte testen und berichten ob es gefällt, dann kommt das auch in die nächste Version vom Mountie4GP2


    LG
    gutemine


    EDIT: script imit automatischem swapfile enabeln ist jetzt im 1.0 kit enthalten

    Edited 5 times, last by gutemine ().

  • Ich liebe solche monologthreads.


    Noch eine kleine Frage bevor ich am Abend die neue version mache - wäre es noch eine Bereicherung wenn das udev_mount.sh auch noch gleich bei allen devices ein movie directory anlegt beim mounten (oder nur bei denen die als harddisk gelabelt sind und das filesystem ext3 ist,, oder ...)


    Weil damit haben auch manche noch ernsthaft Schwierigkeiten die Ihnen Mountie4GP2 aber auch leicht abnehmen könnte.


    LG
    gutemine

    Edited once, last by gutemine ().

  • hmm wird nun nicht der movie ordner automatisch von e2 angelegt wenn er nicht vorhanden sein sollte :rolleyes:

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Frag mich das doch nicht - ich baue es halt einfach mal ein das wenn keiner da ist er angelegt wird - stört ja nicht und sind nur 3 codezeilen

  • OK, ich habe jetzt die 'finale' Version 1.0 am Anfang des Threads gepostet, nachdem sonst keine Inputs oder Fehlerberichte mehr gekommen sind und ich so weit alles bisher diskutierte eingebaut habe, nur für das stranded directories aufräumen hatte ich noch keine Lust :-)


    LG
    gutemine

    Edited once, last by gutemine ().

  • hi gutemine!


    danke wiedermal für das plugin! läuft soweit, wie es soll. denn sinn, automatisch ein verzeichnis movie auf jedem device anzulegen, sehe ich zwar nicht ganz;)


    einen input hätte ich noch: deinstallieren des mounties (nicht mountie4gp2) funktionierte nicht ganz- sowohl über die konsole als auch über den pluginbrowser. das plugin wurde zwar nicht mehr im pluginbrowser angezeigt, es waren jedoch noch dateien in us/lib/enigma2/python/plugins/extensions/ vorhanden und mussten von hand entfernt werden.


    mfg, el_sasasa

  • In der Version 1.0 ist ein rm -r
    /usr/lib/enigma2/python/Plugins/Extensions/Mountie4GP2 im uninstall script dabei, insofern soltle der fehler schon gefixed sein.


    Und du hättest nur sagen müssen wie du das movie directory haben willst, jetzt wird es halt überall angelegt damit man auch überall aufnehmen kann - aber du hast schon recht für ein mit hdd gelabeltes device hätte auch gereicht.


    Aber nachdem sich keiner gerührt hat war ich halt faul und ein directory tut ja nicht weh und das enigma2 freut sich halt :-)


    PS: es wird sicher mal eine 1.0_r1 geben, also kein stress, das directory aufräumen muss ich ja auch noch machen, aber mit war halt so nach releasen, schon weil jetzt in der 1.0 die BA devices ignoriert werden (was deren label angeht), weil das brauchte ich um endlich am BA weiterbasteln zu können.


    LG
    gutemine

    Edited 3 times, last by gutemine ().

  • find ich eine gute idee, nur im hdd-gelabelten device das verzeichnis movie zu erstellen (zu mindest für computer-legasteniker, die nicht selber dazu befähigt sind^^) aber hast schon recht, ein ordner tut niemandem weh:)


    jaja, und läuft immernoch stabil, alle anstrengungen einen fehler zu produzieren scheitern bislang:D


    mfg, el_sasasa


  • Hi,


    wollte dich gerade um genau das bitten in diesem Thread. :) Vielen Dank für deine schnelle Hilfe. Hast wirklich ein tolles Plugin geschrieben!!!


    lg sleepy789

    Don't dream your life, live your dreambox...


    Gemini4 @ Merlin4 OE2.5
    Dreambox 7080
    ______________________________________________

  • das Plugin ist gar nicht so aufregen, das Hautproblem war bis ich alle verschiedenen disklabeltools zusammen und am laufen hatte.


    Mountie ist aber ja eigentlich entstanden weil ich mit den derzeitigen automounts noch nicht happy war, und das Mountie4GP2 ist davon nur ein Ableger um zu zeigen wie ich mein udev gerne bei der Arbeit hätte.


    Das echte Problem ist das Mountie zwar nett ist aber duch die vielen disklabel binaries und libs eigentlich zu groß ist um es fix in den images zu verbauen.


    Ich suche immer noch nach eine single binary das ext3/FAT und NTFS labeln kann - bis jetzt habe ich immer noch nichts gefunden - wobei ich auch nicht sehr intensiv suche, und noch ein paar Tools ausprobieren muss.


    Das problem ist halt das das ganze Partition labeling aus der Steinzeit stammt und mehrmals aufgebohrt wurde, womit scheinbar sich noch keiner die arbeit gemacht hat ein all in one labeling tool zu machen.


    Theoretisch bräuchte ich eh nur label lesen, weil man könnten man das FST/NTFS labeln aus dem Plugin rausschmeissen (das kann eh jeder PC besser) und das tune2fs kann eh auch ext3 labeln, bzw. kann man den label ja gleich beim formatieren angeben udn dann wäre ruhe.


    Na ja mal sehen, wo die Reise hinführt.


    LG
    gutemine

    Edited once, last by gutemine ().

  • Quote

    Original von el_sasasa
    find ich eine gute idee, nur im hdd-gelabelten device das verzeichnis movie zu erstellen (zu mindest für computer-legasteniker, die nicht selber dazu befähigt sind^^) aber hast schon recht, ein ordner tut niemandem weh:)


    jaja, und läuft immernoch stabil, alle anstrengungen einen fehler zu produzieren scheitern bislang:D


    mfg, el_sasasa


    Ist jetzt in der 1.0 r1 so gelöst das nur wenn du ein device hdd labelst ein movie ordner drauf angelegt wird.


    LG
    gutemine

    Edited once, last by gutemine ().

  • Folgendes Problem mit D8000 GP2 4.20 auf CF und OoZooN im flash (aktuell).


    MountiGp2 installiert, wird auch auch unter show mounts alles mit label angezeigt.
    Externe Fetsplatte (NTFS) mit Label My Passport front USB angeschlossen,
    unter show mounts wird sie mit sde1 label My Passport angezeigt.
    Unter dem Dateimanger finde ich aber kein Mountpunkt My Passport.
    Sie wird wie unter show mounts angezeigt als sde1 gemountet.
    Nach einem Neustart mit Festplatte angesteckt, wird diese dann als sdb1 gemountet. Anzeige unter show mounts ist dann sbd1 mit label My Passport.

  • Leerzeichen im Namen wären schwer zu mounten, eigentlich sollte Mountie dann die Leerzeichen entfernen, im Falle des udev im Shellscriot wird das aber scheinbar nicht gemacht womit wieder der default label verwendet wird.


    Probier halt mal MyPassport als Label - am Besten am PC einfach umbenennen.

    Edited 2 times, last by gutemine ().

  • bevor die Fragerei losgeht, die 1.1 vom Mountie4GP2 am Anfang des threads basiert jetzt auf dem udev_mount.sh script vom Gemini2 4.3 - geht aber auch im 4.2 natürlich installieren, so viel hat sich da (leider) auch nicht geändert (1.0 ginge auch noch im 4.3, aber was soll es, die paar zeilen waren schnell angepasst).


    LG
    gutemine

    Edited once, last by gutemine ().