[Rel. 1.1 special "Sonic"] OpenPanel E²

  • install: (Vorrausetzung OP-0.8 & Multi QuickButton 1.0)


    nach /tmp via ftp auf die Box

    Code
    root@dm8000:/# cd /
    root@dm8000:/# tar xzvf /tmp/OP-yellow.tar.gz


    ohne reboot nur "Gelb" drücken und frunzt... :D
    viel Spass


    Emanuel ;)

    Files

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

    Edited once, last by emanuel ().

  • Danke ;)

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • emanuel
    vielen Dank dafür, das ist schon fast genial


    fast, weil ich wie immer irgendwie noch extra-Wünsche habe:
    könnte ich haben


    - deaktivieren des multiquickbutton für bereits belegte Buttons (er überschreibt ja anscheinend alle?)


    oder ist alles schon da und ich bin heute wirklich blind?


    ach so: und ein besonderer extra Dank für die extrem einfache Verwendung, das Belegen der Buttons ist ja so ein absolutes Kinderspiel


    edit:
    - die Menüs auf den Quickbuttons auch mit shortcut für schnelleren Zugriff?
    ist ja Quatsch, habe ich ja wenn ich OP-xml aufrufe

    Edited 2 times, last by shadowrider ().

  • hi


    kann man auch irgendwie die usersripts direkt auf die gelbe taste legen?

  • Quote

    kann man auch irgendwie die usersripts direkt auf die gelbe taste legen?


    warum nicht? trage es in der entsprechenden xml ein, drücke bei aktiviertem MultiQuickbutton die gelbe Taste und wähle es als aktiv aus
    (in der vorhanden xml siehe Mount info)

    Edited once, last by shadowrider ().

  • aber für den Anfang vieleicht etwas viel.
    ich mache ein kleines howto im Post.

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • hi


    ich weiss leider nicht, wie ich das machen soll. könnt ihr mir dabei helfen?

  • hi


    habe probiert und es nicht hinbekommen. kann mir irgendeiner helfen mit den userscrits auf der gelben taste?
    ich will den ganzen menüpunkt auf die gelbe taste, habe einige userskipts mit denen ich mein netzwerk steuere (mehrere rechner und ein server), starten und ausschalten


    komme leider nicht weiter mit den multiquickbutten :359:

    Edited once, last by svs ().

  • edit: falscher Thread

    Edited once, last by shadowrider ().

  • emanuel, beim Aufruf des Zap-History Browsers kommt es bei mir zum Buntscreen!?


    crashlog...
    ---
    [OpenPanel] start plugin Zap-History Browser
    [OpenPanel] found plugin : Zap-History Browser
    Traceback (most recent call last):
    File "/usr/lib/enigma2/python/Components/ActionMap.py", line 66, in action
    return ActionMap.action(self, contexts, action)
    File "/usr/lib/enigma2/python/Components/ActionMap.py", line 46, in action
    res = self.actions[action]()
    File "/usr/lib/enigma2/python/Plugins/Extensions/OpenPanel/OpenPanel.py", line 329, in go
    self.goEntry(cursel[0])
    File "/usr/lib/enigma2/python/Plugins/Extensions/OpenPanel/OpenPanel.py", line 359, in goEntry
    self.execPlugin(entry[2])
    File "/usr/lib/enigma2/python/Plugins/Extensions/OpenPanel/OpenPanel.py", line 139, in execPlugin
    plugin(session=self.session)
    TypeError: main() takes exactly 2 non-keyword arguments (1 given)
    (PyObject_CallObject(<bound method NumberActionMap.action of <Components.ActionMap.NumberActionMap instance at 0x30c476c0>>,('WizardActions', 'ok')) failed)
    ---


    Dumm ist, dass das Plugin irgendwann im "blue=Extentionmenu" nach unten durch gereicht wird und somit kein shortcut mehr funkt - je nach Anzahl installierter Plugins.
    Ich vermute aber ehr das es am Plugin selber liegt!? Verschiebe ich es ins "Pluginmenu" und rufe es von da auf kommt auch ein BS!?


    Schade ist auch, dass wenn man - wie bei einigen Plugins möglich - den Eintrag aus dem Extention Menu entfernt (Partnerbox Plugin) diese auch nicht mehr vom Openpanel gestartet werden können!?


    PS. Dein MultiQuickbutton habe ich noch nicht getestet. Evtl. funktioniert es ja hiermit...werde ich gleich mal installieren.


    Gruß
    ModeOne

  • Siehe Beispiel Grafisches MEPG in /etc/plugins.xml


    im Nächsten ist es schon drin, aber das wird noch nicht veröffentlicht :D


    Gruss Emanuel ;)

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594


  • enjoy...
    CYA Emanuel ;)

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • aus der Bastelstube geholt.


    siehe erste Seite.


    Gruss Emanuel ;)

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • nabend


    ich hätte da mal ne frage


    ich würde gern im open panel den sofwaremanager unter einstellungen zum laufen bekommen
    nur bringt er mir immer wieder eine fehlermeldung das er den softwaremanager nicht findet


    Code
    PluginDescriptor.WHERE_MENU


    ich habe diesen eintrag in die e2Plugins hinzugefügt leider brachte das auch nichts; es kann auch sein das meine überlegung total falsch ist ?(


    wer kann helfen??


    mfg