error: Entry 'packages/enigma2/enigma2-plugins.bb' not uptodate. Cannot merge.

  • /home/mrcop/dreambox/openembedded/1.5/openembedded/packages
    cd /home/mrcop/dreambox/openembedded/1.5/openembedded && git pull
    Updating 86127d5..62fc2b0
    packages/aio-grab/aio-grab.bb: needs update
    packages/enigma2/enigma2-plugins.bb: needs update
    packages/enigma2/enigma2-skins.bb: needs update
    packages/enigma2/enigma2-streamproxy.bb: needs update
    packages/enigma2/enigma2.bb: needs update
    packages/libdreamdvd/libdreamdvd.bb: needs update
    error: Entry 'packages/enigma2/enigma2-plugins.bb' not uptodate. Cannot merge.
    make: *** [openembedded-update] Fehler 128



    Kann mir jemand sagen wie ich diesen fehler beheben kann.
    Scheint was mit git update nicht zu stimen.

  • Es gibt gestimmt bessere Möglichkeiten, aber das können die git-Fachleute mal erzählen.


    Diese Methode hilft aber auch:
    Achtung! Änderungen die du in den *.bb Dateien gemacht hast werden überschrieben, mach also gegebenenfalls Sicherungskopieren der genannten Dateien.


    Code
    cd /home/mrcop/dreambox/openembedded/1.5/openembedded
    git checkout -f
    git pull


    Danach müstest du aber wieder das SRCDATE und die Revision eintragen , die du haben möchtest.

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • Thx hat geklapt !!!


    Mal sehen was mein Ubuntu draus macht.

  • NOTE: package enigma2-2.5git20090131: started
    NOTE: package enigma2-2.5git20090131-r0: task do_install: started
    ERROR: function do_install failed
    ERROR: see log in /home/mrcop/dreambox/openembedded/1.5/dm800/build/tmp/work/enigma2-2.5git20090131-r0/temp/log.do_install.8885
    NOTE: Task failed: /home/mrcop/dreambox/openembedded/1.5/dm800/build/tmp/work/enigma2-2.5git20090131-r0/temp/log.do_install.8885
    NOTE: package enigma2-2.5git20090131-r0: task do_install: failed
    ERROR: TaskFailed event exception, aborting
    NOTE: package enigma2-2.5git20090131: failed
    ERROR: Build of dreambox-image failed
    make: *** [image] Fehler 1



    wie erwartet blieb git wider stur.


    kann es nicht installieren (enigma2-2.5git20090131-r0: task do_install: starte)

  • Och man eh, wieso kann keiner die logfiles anhängen?
    Na was steht den nun in log.do_install.8885 ???

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook