howto wie man eine e1 box mit einer e2 box (und auch umgekehrt) mittels automount verbindet

  • ziel diese howto ist es die interne hdd einer e1 box mittels automount auf einer e2 box zu mounten, und das ganze natürlich auch in umgekehrter reihenfolge,so das man auf jeder box auch die aufnahmen der anderen box ansehen kann.


    dieses howto ist auf das gemini 4.x ausgerichtet.


    edit: rev.0.2 - fehler bereinigt + ergänzungen
    edit: rev.0.3 - ergänzungen + ausdruckbar


    Quote

    rev.0.1 - 77 mal heruntergeladen


    Quote

    rev.0.2 - 112 mal heruntergeladen


    Quote

    rev.0.3 - 3022 mal runtergeladen


    edit: anhang entfernt da im gp-wiki vorhanden

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

    Edited 3 times, last by JackDaniel ().

  • - Thank you very much for the very good job !!!!!


    - Is it easy to translate the pdf file from German to English ????


    - It would be very helpful !!!


    - Thanks a lot !!!

  • :335:


    Das Ding kam genau zur richtigen Zeit, nachdem ich jetzt 2 Nächte dran gesessen habe und es nicht geschaft habe die 7000er auf der 800 sichtbar zu machen. Naja, Denkfehler. Ich dache ich muss auf media/nfs mounten :( so wie es auch auf der 7000 ist.

  • warum läßt du das ausdrucken deiner PDF-Datei nicht zu ?

    1. Box: 800se, 500 GB HD
    2. Box: 500-S,
    3. Box: 800-S, 250GB HD
    in allen Boxen die neuste Software

    Edited 2 times, last by condor ().

  • korn,
    it is not only the textual part to be translated to any language,
    it is also all the OSD images on an English chosen local dream box
    thus it demands some extra time for anyone who would want to invest the Time.


    on the other hand
    although some won't like it, German is one of the leading Languages which ought to be part of your education.


    cheers

    bin nicht sicher, ist Anne Will ministerin?

    Edited once, last by Tonskidutch ().

  • Klasse Anleitung vielen dank!
    Vielleicht sollte man aber noch ergänzen, dass wenn es mittels TCP-Protokoll nicht geht man es mit UDP probieren sollte. Bei mir klappte die Verbindung nur mit UDP, bei TCP meldete DCC "FTP component not ready".

  • Quote

    Original von Bladestar
    Klasse Anleitung vielen dank!
    Vielleicht sollte man aber noch ergänzen, dass wenn es mittels TCP-Protokoll nicht geht man es mit UDP probieren sollte. Bei mir klappte die Verbindung nur mit UDP, bei TCP meldete DCC "FTP component not ready".


    und genau das ist ja das interessante, bei drei verschiedenen netzwerken habe ich es bis jetzt nur satbil mir der option tcp zum laufen gebracht


    und nun kommst du, und bei dir geht es nur per udp :rolleyes:


    was ja eigentlich sehr widersprüchlich ist, das tcp protokoll zu verwenden da es ja zum udp einen "overhead" im netzwerk verursacht.


    ps: hast du es mal mit und einmal ohne die ports versucht ?

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Quote

    Original von JackDaniel
    ps: hast du es mal mit und einmal ohne die ports versucht ?


    Habs eben mal ohne Ports probiert, gleicher Effekt.
    Mit UDP klappt es auf anhieb einwandfrei.


    PS: Könntest du bitte den "Kopierschutz" aus dem PDF entfernen? Das wäre für manchen Copy&Paste User wesentlich bequemer :D

  • Quote

    Original von condor
    warum läßt du das ausdrucken deiner PDF-Datei nicht zu ?


    weil ich wissen wollte wie lange es dauert bis einer danach fragt ;)


    spass beiseite, ich werde es in der rev.0.3 ändern ok

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Quote

    Original von Bladestar
    PS: Könntest du bitte den "Kopierschutz" aus dem PDF entfernen? Das wäre für manchen Copy&Paste User wesentlich bequemer :D


    nein das werde ich sicher nicht, wenn jemand ein howto oder etwas in der art machen will dann soll er sich die arbeit machen und es sich selbst erarbeiten.


    wenn jeder dann noch anfängt darauf herum zuschustern gibt es am ende wieder nur chaos, und das bringt keinem was


    wünsche,beschwerden oder anregungen werden gerne angenommen, und wenn es das wissen und die zeit zulässt auch umgesetzt ;)

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • JackDaniel,


    das UDP <> TCP wurde in ein ganz anderes Thema der Berichten auch am 14.07.2005 14:57 diskutiert
    das haengt wohl damit zusammen ob im LAN ein ROUTER und oder ADSL-router/modem haengt welches Probleme hat mit UDP


    es ist halt bei die verschiedenheit an Modelle und Fabrikate der ROUTER (bei einige Dreamboxler zuhause) nicht so eindeutig ob Ihr router UDP blockt...
    meistens sind die router ja auch gleich firewall


    sollte man das in verbindung mit NFS mounten weiter verfolgen, kommt man drauf das dieses native file system eigentlich in ein LAN immer mit UDP funzt wenn die diesbezuegliche HOSTS ueberall bekannt sind.
    abgesehen von password authentifizierung welches ja beim NFS scheinbar nicht gefordert ist
    muss aber trotzdem die "End-adresse" wo es ankommen sollte ein offener teilhaber sein in die WORKGROUP und nicht per protokoll geblockt werden mittels ROUTER


    Ich habe das mounten ja jetzt auch mal mittels TCP eingestellt als test aber hier funzt beides am SpeedTouch alcatel


    Einige ROUTER sind ja von aussen DSL oder ADSL "administered" und koenne sein das UDP geblockt ist


    Also, die Frage; ob UDP oder TCP zollte man entweder vorab klaeren oder testen.
    TCP hat offensichtlich vorteile in Transportsicherheit
    aber
    UDP hat vorteile in sachen Transportgeschwindigkeit


    bei UDP kann es aber zu fehler kommen wenn zuviel im LAN herum genoergelt wird.


    chiao

    bin nicht sicher, ist Anne Will ministerin?

  • Danke erst mal für die Beschreibung !
    Leider funktioniert es bei mir nur zum Teil.
    Ich habe mich nach bestem Wissen und Gewissen an die Beschreibung gehalten :gutenmorgen:



    Auf meiner DM 800 ( Gemini 4.0) sehe ich die Dateien (Filme) der DM 7020 und kann diese auch mit dem Mediaplayer abspielen. Der Ordner "autofs" ist vorhanden.


    Auf der DM 7020 (Gemini 4.6 auf CF) sehe ich die 800er gar nicht. Der Ordner "automount" ist nicht vorhanden oder wird nicht angelegt.


    Die Boxen sind im Netzwerk natürlich sichtbar und erreichbar.


    Wo könnte der Fehler liegen?


    Grüsse

    DM7020S, DM800HD
    [SIZE=7]Eine Frau und 3 Kids[/SIZE]

    Edited 5 times, last by mitsch ().

  • Hallo,


    es klappt einfach nicht - habe mich an die obige Beschreibung gehalten, allerdings tritt folgendes Problem beim Versuch über FTP(DCC) den autofs Ordner(DM7000) mit den Filmen der DM8000 zu öffnen auf - TRANSFER DONE (but failed to open directory) - demnach lassen sich die Aufnahmen auch nicht auf der 7000er aufrufen.


    Anders herum klappt das bestens (DM8000 zugriff auf Filme der DM7000).
    Habe bereits so einiges probiert - brachte allerdings nichts.


    DM 7000 - 192.168.2.26 - Gemini 4.50
    DM 8000 - 192.168.2.27 - Gemini 4.00


    Inhalt der automount.config (DM 7000):


    DM-8000 -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.2.27:/media/hdd/movie


    Inhalt der auto.hotplug (DM 8000):


    DM-7000 -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.2.26:/var/mnt/hdd/movie


    Auf beiden Boxen lassen sich die freigegebenen Ordner bzw. Rechner mit den freigegebenen Ordner per telnet - exportfs ohne Probleme ansprechen.
    Auf beiden Boxen sind auch unter autofs die Boxen (Ordner)sichtbar - allerdings lässt sich nur der Inhalt der 7000 auf der 8000 öffnen.
    Auf beiden laufen die NFS-Server.
    Freigegeben Ordner sind auch vorhanden.


    Muß ich noch irgendwelche attribute bzw. Freigaben setzen?
    Da ich nun mit meinem Latein am Ende bin, freue ich mich auf jedwelche Unterstützung.
    Vielen Dank.


    lg
    tomc@t

    lg tomc@t


    Pioneer PDP 506XDE - BOSE lifestyle 135 - Pioneer BDP 320
    DB 8000HD(DVD/HD 1TB) - DB 500HD - NAS QNAP TS 439PRO 4x1TB (RAID 5) - Logitech Harmony One

  • 1. denn tip mit denn ports ausprobiert ?
    2. denn tip mit udp ausprobiert ?
    3. es gibt auf der 7000er keinen ordner namens autofs ;)

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • ............habe leider nur bei der 800er ein Gemini im Flash gehabt.
    Bei der 7020 Gemini nur im Multiboot. :O
    Einen Hinweis darauf in der Beschreibung wäre gut.
    Hab ich geändert.
    Jetzt ist der Ordner der 800er auch sichtbar........aber leider ohne Inhalte (gleiches Phänomen wie bei Tomc@t)


    Ich habe mit DCC die automount.config der 7020 editiert ........TCP......... und festgestellt, dass wenn ich in der Box selbst den Automount anschaue dort dann immer noch ........udp...... steht. Nach einem Reboot sieht es genau so aus.


    Irgendwie scheint die Box diese Befehlszeile nicht wirklich zu übernehmen.


    würde mich über weitere Tips freuen
    Gruss Mitsch

    DM7020S, DM800HD
    [SIZE=7]Eine Frau und 3 Kids[/SIZE]

  • @ JackDaniel


    zu 1. Port ein / aus keine Lösung
    zu 2. Udp bzw Tcp getestet - funkt genausowenig
    zu 3. oh sorry.


    @ mitsch


    bei mir dasselbe - automount (Box) - Udp - automount.comfig - tcp manuell eingegben ???


    lg
    tomc@t

    lg tomc@t


    Pioneer PDP 506XDE - BOSE lifestyle 135 - Pioneer BDP 320
    DB 8000HD(DVD/HD 1TB) - DB 500HD - NAS QNAP TS 439PRO 4x1TB (RAID 5) - Logitech Harmony One

  • tomc@t
    poste mal die ausgabe von exportfs -v von der 8k bitte

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • .........bin zwar nicht direkt gefragt worden...........aber vielleicht hilft es allen etwas weiter.
    Bei mir sieht die Ausgabe wie folgt aus:


    /media/hdd/movie 192.168.0.222/255.255.255.0(rw,async,wdelay,no_root_squash)


    Gruß Mitsch

    DM7020S, DM800HD
    [SIZE=7]Eine Frau und 3 Kids[/SIZE]

  • mitsch


    schön wäre es zu wissen von welcher box das ist ;)

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Sorry,


    diese Ausgabe ist von der DM 800


    Meine zweite Box ist eine 7020S


    Gruss Mitsch

    DM7020S, DM800HD
    [SIZE=7]Eine Frau und 3 Kids[/SIZE]