Audio Sync Plugin V1.2 (aka AC3 Lip Sync)

  • Hallo Zusammen


    danke erst mal für die genialen Antworten.


    Der Tipp von Stephan mit dem Kannal editor scheint zu funzen (bin nicht fertig aber habe das Editieren ausprobiert und das geht soweit. Danke an Dich.


    bin heute Abend erst spät von der Arbeit gekommen...
    und habe den Abend verbracht eueren Anweisungen zu folgen.
    leider ohne Erfolg.


    Vorschlag 1 von msg11
    habe die Datei in den Pfad wie beschrieben kopiert und eine komplett Neustart durchgeführt. Irgendwie habe ich aber bei den Erweiterungen das Problem das in nur auf die Setup Einstellung komme. Der gelbe button ist bei mir mit dem Blue Panal belegt. Einzelne Ausführungsbefehle direkt im AudioSync order wurden mit Berechtigungshinwies nicht ausgeführt.


    Vorschlag 2 von Swiss-MAD


    leider bin ich zu nicht in der Lage (zu blöd) den Befehl einzugeben. Habe das mit dem DCC-E2 versucht mit Tools Kommando senden.
    Mit dem tellnet befehl kam die Antwort zurück :
    find: grep: No such file or directory
    find: audio_delay_bitstream: No such file or directory


    in der GUI kann ich weiterhin nur +- 1000 eingeben.


    Bitte noch mal etwas ausführlicher beschreiben was ich tun muss noch blick ichs nicht!!


    Guss


    rolipoli

  • Quote

    Original von rolipoli
    Habe das mit dem DCC-E2 versucht mit Tools Kommando senden.
    Mit dem tellnet befehl kam die Antwort zurück :
    find: grep: No such file or directory
    find: audio_delay_bitstream: No such file or directory


    Ja in DCC unter Telnet kannst du die Befehle absetzten.
    Mach einfach Copy&Paste.
    Ich glaube du hast dein Befehl in 2 Stücke "geschnitten".
    Alles was in einer Zeile in anderem Font steht ist EIN Befehl.


    Also z.b.:
    find /proc/ | grep audio_delay_bitstream


    Aber das ist nur mal zum manuellen Checken wie weit es geht, und das Delay ist nach einem Reboot auch wieder auf Null.
    Das Plugin macht erst mal nichts anderes, mit der Ausnahme das das Globale Delay gespeichert wird, und man auch für Einzelne Sender eigene Werte setzten kann, die dann in der Kanalliste gespeichert werden.

  • Quote

    Original von rolipoli


    Vorschlag 1 von msg11
    habe die Datei in den Pfad wie beschrieben kopiert und eine komplett Neustart durchgeführt. Irgendwie habe ich aber bei den Erweiterungen das Problem das in nur auf die Setup Einstellung komme. Der gelbe button ist bei mir mit dem Blue Panal belegt. Einzelne Ausführungsbefehle direkt im AudioSync order wurden mit Berechtigungshinwies nicht ausgeführt...


    rolipoli


    Also ich selbst nutze ein DMM Image ohne GP3, sprich kein BP. Das Setup erreich über den PluginBrowser (Schrittweiten festlegen, Verzögerungsamplitude...). Dank des Edits müsstest du im Setup die Grenzen (+/-) weiter ausreizen können, in meiner Beispieldatei halt bis 90000 bzw -90000. Verwenden kannst du das AudioSync ja eh erst über ein anderes Menü. Da kommst du ja etwas anders hin. Ist also nicht im Plugin-Browser versteckt. Audio-Taste -> grün "Menü" (Bild 1) -> blau "AudioSync" (Bild 2) -> ausführende Pluginoberfläche (Bild 3). Ist etwas irritierend, im ersten Audio-Untermenü komm ich selbst noch nicht über gelbe Taste in AudioSync, muss mittels grüner Taste nochmal weiter, wo man auch sonst den Untertitel auswählen kann. Habe der Nachvollziehbarkeit halber mal die Screenshots angefügt, auf die ich auch bereits oben verwiesen habe. Hoffe, jetzt klappts.

    Files

    • Bild 1.jpeg

      (27.5 kB, downloaded 1,008 times, last: )
    • Bild 2.jpeg

      (22.08 kB, downloaded 972 times, last: )
    • Bild 3.jpeg

      (17.5 kB, downloaded 992 times, last: )

    Edited 3 times, last by msg11 ().

  • Quote

    Original von msg11
    Ist etwas irritierend, im ersten Audio-Untermenü komm ich selbst noch nicht über gelbe Taste in AudioSync


    Das wird wohl daran liegen das die DM8000 die neue Fernbedienung hat.
    Die alte hat eine eigene [AUDIO] Taste, die ist bei der neuen unter [gelb].
    Dafür sind bei der neuen die Farbtasten nicht doppelt belegt, weil die hat eine Tasten-Reihe mehr.

  • Quote

    Original von Swiss-MAD


    Das wird wohl daran liegen das die DM8000 die neue Fernbedienung hat.
    Die alte hat eine eigene [AUDIO] Taste, die ist bei der neuen unter [gelb].
    Dafür sind bei der neuen die Farbtasten nicht doppelt belegt, weil die hat eine Tasten-Reihe mehr.


    Tatsache, hab mir die FB zur 8000er im Internet rausgefunden. Also wie du in dieses Audio-Menü kommen kannst, weiss ich nicht, habe halt eine andere FB: http://wiki.blue-panel.com/index.php/Bild:Fernbedienung.jpg, (danke Swiss-MAD) da gibt es halt noch die AUDIO-Taste, hoffe, das klappt trotzdem noch irgendwie...


    was meinst du eigentlich damit: "Einzelne Ausführungsbefehle direkt im AudioSync order wurden mit Berechtigungshinwies nicht ausgeführt."

    Edited 3 times, last by msg11 ().

  • Ach, ich habs einfach noch ein wenig weiter umgeschrieben. Jetzt kommst du ins AudioSync, also nicht Setup, sondern das AudioSync auch über den Plugin-Browser.


    zu Swiss-MAD, unterer Beitrag :)


    Die Belegung selbst leuchtet mir auch ein. Ton-Verzögerung ins Audio-Menü. Aber wenn er halt die gelbe Taste mit dem BP belegt hat und nicht ins AUDIO-Untermenü kommt??? Ich weiss nicht, ob man es halt noch irgendwie umbelegen kann. rolipoli Kannst es dir ja mal angucken, also es klappt auf jeden Fall auch so, über den Plugin-Browser.

    Files

    • plugin.py

      (1.96 kB, downloaded 26 times, last: )

    Edited once, last by msg11 ().

  • @msg11


    Bei deinem Link zu der Fernbedienung musst du am Ende noch das "," weg machen. Sonst geht der nicht.
    Bei der neuen Fernbedienung ist das AudioMenü Standardmässig auf der gleben Taste.
    Weil die braucht man ja nun nicht mehr für Timeshift / Pause weil diese Taste ja nun separat ist.
    Aber man kann sich ja mittlerweile mit Quickbutton so einiges einstellen wie man will.


    Und die Delayeinstellung ist absichtlich im Audiomenü.
    1. Weil das der logisch Platz ist.
    2. Weil man das auch erreichen kann wenn z.b. eine Aufnahme abgespielt wird.


    Aber für das Problem von rolipoli müsste in erster Linie das setzten des globalen Delays ausreichen.


    (Ich kann immer noch nicht glauben wie Samsung sich das vorstellt, wenn die eine soooo extreme Verarbeitungsgeschwindigkeits differenz zwischen Audio und Video haben.
    Was machen da alle anderen die keine Dream haben ? Da ist man ja auf einen AV-Reciever angewiesen der solche Delays machen können.)

  • Jpieeeeeeee!!!!


    Unglaublich es funzt !!!!!!!!!!!!!!!!!!!!!


    Ich bin begeistert!!!!!!!!!!!!!!!!!!!


    Ein Wahnsinns DANKE an euch und speziell DICH msg11 !!!!


    also ich habe dein keines update auf die Box geschoben und den Neustart durchgeführt. In den der Erweiterung ist nun auch das Plugin aufzurufen. Ich habe sogleich mit den globalen Werten die Einstellung durchgeführt Bei ca 2600 - 2800ms hat der Ton ausgesetzt. Zum glück reicht eine Einstellung von ca. 1750ms. Das ist ja schon ein fetter wert und ich gebe Swiss-MAD recht, wer keine solch Einstellmöglichkeit hat sieht verdammt alt aus....



    Nochmals vielen dank an Euch zwei Swiss-MAD und msg11 das ihr das so fix auf die Reihe gebracht habt


    Ach ja, global ist völlig ok für meinen Fall. Gilt für normalen Sat Empfang und PVR abspielen. Alles passt .


    Einfach genial !!!! :hurra: :hurra: :hurra:


    Gruß


    rolipoli

  • Erst mal von mir auch ein Danke an Swiss-Mad und msg11, dass Ihr Euch der Sache angenommen habt, ich komme momentan einfach zeitlich nicht dazu, selbst den einfachsten Support für meine Plugins zu liefern.


    Jetzt aber mal ne Frage an die Allgemeinheit: Gibt es solche Extremen Delays häufiger?


    Ich meine: 1,7 Sekunden Delay... das kann man ja gar nicht übersehen... Bei mir bewegt sich das immer im 50-70ms Bereich...


    Weshalb ich frage: Ich kann natürlich die Änderung von msg11 ins Plugin- git übernehmen, denn ich denke nicht, dass da irgendwelche Nebenwirkungen zu erwarten sind. Allerdings werde ich den Erfahrungswert von rolipoli einfliessen lassen, und das maximale Delay auf +- 3 Sekunden setzen (wenn der Puffer sowieso nicht mehr aufnehmen kann, macht es keinen Sinn, hier "falsche Hoffnungen" zu nähren...


    Gruss
    Tode

  • Hallo


    Meine Frage: Gibt es für die 7020 (nicht die 7020HD) ein Plugin, was die Verzögerung zwischen Ton und Bild korrigiert, ähnlich wie das Audio Sync Plugin ?


    Bei mir kommt das Bild schneller als der Ton, äußerst nervig.


    Ich habe nichts passendes gefunden.



    MfG


    Jaipaul

  • dank für die Antwort.


    Ich hab gelesen, dass es externe Konverter geben soll, die dieses Problem lösen sollen. Hat jemand so ein Teil oder kann jemand sowas empfehlen?


    Gruss


    Jaipaul

  • Weiß jemand ob das Plugin auch mit OE2.0 läuft ?

  • ich versuche die audiospur über mehrere sekunden zu verschieben, und nicht nur einige ms



    fussballspiel läuft auf 2 kanälen:


    1 tuner gibt mir das bild und der 2. tuner den ton....


    die singale sind dort soo weit auseinander dass dies nicht reicht.




    ist es möglich über 30sec den ton zu verschieben?

  • manufact


    Ich denke, der Buffer ist dafür zu klein. Zumindest glaube ich das vor laaaaanger Zeit mal für die "alten" Boxen gehört zu haben.
    Bei den "neuen" Boxen kann ich mir aber kaum vorstellen das der Buffer nun dermassen gross geworden ist.

  • das sollte auf der HDD oder USB stick buffern


    timeshift funktion kann das ja auch....

  • Das kannst du so nicht vergleichen. Timeshift passiert viel früher in der Signalverarbeitung.
    Ganz grundsätzlich bezweifel ich, dass ein USB-Stick oder gar eine HDD dafür schnell genug sind. Und dabei geht es nicht um die Übertragungsgeschwindigkeit, sondern die Latenzen.


    Aber das ist theoretisch. Was du willst, benötigt Anpassungen von DMM.

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul: