skin2ipk und plugin2ipk Tool

  • Hallo,


    Danke für den Hinweis :winking_face:


    Ich würde bei den Skins das gerne an die Enigma2 Version abhängig machen.
    Daja gerade bei den neueren Images, denke ab 3.2.1 die neue Fernbebienung der DM7020HD mit eingebracht wurde.


    Und wenn man da ja nun einen älteren Skin installiert und die "Help-Taste" drückt gibts es ja einen Crash


    Da ja der neue Skin von mir da angepasst wurde, soll der natürlich auch nur auf Images installiert werden
    können wo sichergestellt ist das es dann eben keinen Crash gibt beim Aufruf der Help-Taste...


    Bei den alten war ja der Aufruf so:

    Code
    <widget name="rc" pixmaps="skin_default/rc.png,skin_default/rcold.png" ....... />


    Und bei dem neueren Enigma2 lautet ja der Aufruf dann so:

    Code
    <widget name="rc" pixmaps="skin_default/rc0.png,skin_default/rc1.png,skin_default/rc2.png" ....../>


    Also soll der neue SKin ja nur bei dem neueren Enigma2 sich installieren lassen.
    Will also einen typischen Benutzerfehler versuchen zu unterbinden :winking_face:

    MfG EgLe :]

    Linux will Benutzer, die Linux wollen. Linux ist nicht Windows


    Kernel : 5.4.2-1-MANJARO LTS
    GUI : KDE 5.64.0 / Plasma 5.17.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • EgLe


    Kopiere doch einfach einen Symlink zu der entsprechenden PNG mit dem alten Name mit drauf, dann geht es auch bei alten Images. :winking_face:
    Nur so ganz fein ist es nicht weil der Symlink nach /usr/share/enigma2/skin_default/ musst.
    Naja das hätte DMM eigentlich machen sollen.....mindestens für die Übergangsphase.

  • Hallo,


    hmm, denke es gibt da nun zwei gute Möglichkeiten :winking_face:


    Die erste sollte gehen weil ja die neuen Skins nur für die Images ab dem neuen Secondstageloader
    laufen, aber da weiß ich nicht zu 100% ob es direkt bei der Umstellung erfolgte:


    Code
    Depends: dreambox-secondstage (>=83)




    Die zweite wäre aber eher der bessere Weg, aber leider weiß ich da nicht die genaue Enigma2 Umstellung:


    Code
    Depends: enigma2 (>= 2.6git20090926)




    Das bedeutet für die Gemini-Skin wäre das ja dann eine gute Alternative:


    Code
    Depends: geminiplugin, enigma2 (>= 2.6git20090926)


    Oder eben:


    Code
    Depends: geminiplugin, dreambox-secondstage (>=83)


    Oder hötte hier jemand einen besseren Vorschlag?

    MfG EgLe :]

    Linux will Benutzer, die Linux wollen. Linux ist nicht Windows


    Kernel : 5.4.2-1-MANJARO LTS
    GUI : KDE 5.64.0 / Plasma 5.17.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • Quote

    Original von dirtylion
    funktioniert das plugin auch für oe 2.0 ?


    Müsste eigentlich schon.
    Also die "ar" Binary habe ich schon ausprobiert, das geht.
    Und ich wüsste nicht weshalb das Script nicht auch laufen sollte.


    Aber ich verwende sowieso immer nur das ipkg-build.sh Script, und das habe ich ausprobiert.


    Was willst du den "einpacken" ?
    Nimm doch einfach die Files aus dem EMC SVN, und änderst die wenn nötig einfach für dich ab.
    Die aktuellen Files für OE2.0 habe ich eben auf dem SVN-Server geupdated.

  • nachdem sich nur der architecture Eintrag im control file geändert hat musst du das im script halt von mipsel auf mips32el anpassen, dann tun sie weiterhin

  • Hi,


    Tested. Works ok with a OE 2.0 image - with the binary ar included in the plugin.


    Thanks, pcd. :)

    Edited once, last by pcd ().

  • Hello Gutemine,


    I have made a small change to the plugin2ipk script - so that any ipk can be made - not just plugins or skins. It is attached.


    In the Extensions folder - put in the full ipk files (the root items).


    Is there any way I can include also the preinst, postrm etc. and a custom control ?


    Regards, pcd.

  • You may use the ipkg-build script.

    DM 8000 HD + ALPS BSBE2 Tuner
    HDD Western Digital WD10EVDS AV-GP 1TB
    DVD Sony AD 7690H
    Barry Allen Multiboot Konfiguration
    DMM Release 3.2.4 + GP3
    Images auf USB Stick

  • yes, as soon it is not simply packing 1 directory it is easier to build the ipk structure like describedi n Reichi's Wiki and use the standard ipkg-build script


    Ciao
    gutemine

  • Quote

    Original von Swiss-MAD


    Auch wenn du das nicht machen sollst, mit ipkg install -force-overwrite sollte das gehen.


    Hallo Swiss-MAD,


    Möchte das während der Installation die Dateien: EpgList.py und MovieList.py überschrieben werden, wie müsste ich vorgehen.



    MFG

  • Werden sie denn nicht überschrieben, wenn sie in Deinem Installationspaket enthalten sind?


    Du könntest sie ansonsten auch im preinst file löschen:

    Code
    rm -f /usr/lib/enigma2/python/Plugins/Components/EpgList.py
    rm -f /usr/lib/enigma2/python/Plugins/Components/MovieList.py

    DM 8000 HD + ALPS BSBE2 Tuner
    HDD Western Digital WD10EVDS AV-GP 1TB
    DVD Sony AD 7690H
    Barry Allen Multiboot Konfiguration
    DMM Release 3.2.4 + GP3
    Images auf USB Stick

  • Quote

    Original von JuSt611
    Werden sie denn nicht überschrieben, wenn sie in Deinem Installationspaket enthalten sind?


    Du könntest sie ansonsten auch im preinst file löschen:

    Code
    rm -f /usr/lib/enigma2/python/Plugins/Components/EpgList.py
    rm -f /usr/lib/enigma2/python/Plugins/Components/MovieList.py


    Hallo JuSt611,


    Danke für den Tipp. Werde heute dein Vorschlag ausprobieren.

  • Quote

    Original von JuSt611
    Werden sie denn nicht überschrieben, wenn sie in Deinem Installationspaket enthalten sind?


    Du könntest sie ansonsten auch im preinst file löschen:

    Code
    rm -f /usr/lib/enigma2/python/Plugins/Components/EpgList.py
    rm -f /usr/lib/enigma2/python/Plugins/Components/MovieList.py


    Funktioniert so leider auch nicht.

  • Das überschreiben der EPGList.py und MovieList.py habe ich nicht hinbekommen.


    Wie könnte ich eigene liefern?





    MFG

  • verzeichniss-struktur anlegen und die dateien in die richtigen ordner, packen und fertig.

  • Hallo lizard-king,


    Danke für deine Hilfestellen allerdings habe ich nicht verstanden wie du das gemeint hast, sorry.