i-have-a-dreambox.com | Dreambox - Support

Register Calendar Members List Team Members Galerie to Portal Go to the Main Page

Boardrules Frequently Asked Questions Statistik Statistik Search Pinwand Dreambox Blog Ihad/Gemini Fan-Shop
i-have-a-dreambox.com | Dreambox - Support » ...::: Archiv - Support für ältere Dreambox Modelle :::... » ...::: Dreambox und Images DM800 :::... » Allgemeines zur DM800 » Ja, die 800er kann auch komplett von USB booten » Hello Guest [Login|Register]
Last Post | First Unread Post Print Page | Add Thread to Favorites
Pages (12): « first ... « previous 10 11 [12] Post New Thread Post Reply
Go to the bottom of this page Ja, die 800er kann auch komplett von USB booten
Author
Post « Previous Thread | Next Thread »
romeo-golf romeo-golf is a male
V.I.P.*


images/avatars/avatar-9530.jpg

Registration Date: 10.03.2006
Posts: 976
Which box: DM900
External Storage: SD-Card
Which Image: DMM original
Welcher Bildschirm: Samsung 55Zoll UHD

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hi,

ich kämpfe an der gleichen Front. Alle Einstellungen überprüft... BIOS und /autorun.bat. (BA allerdings funktioniert inzwischen einwandfrei.)

Doch erst nachdem ich nochmal von Anfang begonnen habe, wegen dem Tipp die FAT zu formatieren stellte ich wieder fest, dass viele Links wahrscheinlich in den Flashspeicher zeigen statt auf den USB-Stick. Und mit meinen mangelhaften Linuxkenntnissen komme ich dem Fehler nicht auf die Spur :-(

Sehe ich das richtig, dass /MB_Images teil der FAT-Partition wird da ich keine Festplatte in der Box habe? Schließlich ist die FAT-Partition deutlich über 1GB groß (enable 0 0 6)


romeo-golf
15.07.2008 13:05 romeo-golf is offline Send an Email to romeo-golf Search for Posts by romeo-golf Add romeo-golf to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Ja, das /MB_Images wird dann in die FAT Partition kommen, wobei du es natürlich auch auf /media/mbX legen könntest.

Aber machen wir es anders, Ihr müsst sowieso auch testen ob der neue multiboot kit auf der 7025 noch ohne probleme funktioniert.

Ich habe auf seite 6 hier im Thread also einfach mal eine version 8.74 des Multiboot kits gepostet, der kann jetzt auch multiboot.sh link /media/usb oder /media/mbX, .... (allerdings nicht im Plugin, geht nur im Telnet, so viele Leute werden schon keine 800er ohne Festplatte oder wenigstens NAS harddisk haben)

Um die ganzen falschen links loszuwerden einfach neu flashen, und dann eben wenn man keine Festplatte hat gleich nach dem enable die entsprechenden befehle zum umlegen von /MB_Images ausführen. Wenn das dann so klappt wie es soll mach ich Euch das schon noch rein das wenn keine festplatte da ist gleich beim enabeln /media/mbX genommen wird und man es auch im Plugin umlegen kann, gibts halt dann eine 8.75, thowi hatte noch nie schlechtes Gewissen neue Versionen zu machen.

PS: Und mit BA funktioniert einwandfrei meist du da BA 4.5.8 hier aus dem thread + WW ?

weil dann move ich den BA kit endlich in den BA Thread, und wir können hier mit dem Multiboot weitermachen bis das auch so ist wie Ihr es haben woll (aber erst nach dem Urlaub wahrscheinlich)

LG
gutemine

This post has been edited 3 time(s), it was last edited by gutemine: 15.07.2008 18:27.

15.07.2008 18:24
romeo-golf romeo-golf is a male
V.I.P.*


images/avatars/avatar-9530.jpg

Registration Date: 10.03.2006
Posts: 976
Which box: DM900
External Storage: SD-Card
Which Image: DMM original
Welcher Bildschirm: Samsung 55Zoll UHD

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

quote:
Original von gutemine
PS: Und mit BA funktioniert einwandfrei meist du da BA 4.5.8 hier aus dem thread + WW ?


Hi,

ich bin so faul gewesen und habe es bei der 4.5.7 belassen die bei mir einwandfrei läuft. Und ausdrücken wollte damit, dass es mit dem USB-Stick durchaus geht nur eben bei multiboot wird noch irgendwas in die "Irre" geleitet. Und... eine NAS habe ich schon dran, nur ist die in einem der Images auf dem BA-Stick so eingerichtet, dass ich die NAS nicht ständig laufen lasse sondern wenn gewünscht per Script mounte.


quote:
Ja, das /MB_Images wird dann in die FAT Partition kommen, wobei du es natürlich auch auf /media/mbX legen könntest.


Und multiboot betreffend wünsche ich mir natürlich das alle Einstellungen vom Script gemacht werden da ich davon ausgehe, dass ansonsten viele User daran scheitern würden. Und irgendwie war ich der Auffassung, dass die FAT Partition nur wenige KB groß wäre und somit dann /MB_Image ja auf die /mbX verlinkt wird. Nur aus meiner eigenen Anleitung konnte ich nicht mehr ablesen wie man diese /mbX Partition anlegt. (wirklich zu dumm)

Also, ich flashe nachher nochmal neu, werden meinen BA-Stick wieder patchen und danach den multiboot Stick frisch geleert mit der 8.74 neu einrichten. Mal sehen was dann dabei raus kommt. Bei all dem Testen darf ich aber festhalten, dass BA sehr resistent gegen meine Versuche reagiert und Frauchen gar nichts davon bemerkt. Augenzwinkern


romeo-golf
15.07.2008 19:25 romeo-golf is offline Send an Email to romeo-golf Search for Posts by romeo-golf Add romeo-golf to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

na ja das BA ohne WW geht wissen wir schon länger.

Aber nur die 4.5.8 geht auch (hoffentlich) mit WW :-)

wenn du beim enable die richtigen Größen angibst kannst du das FAT fast beliebig gross machen (ich glaube bis 2GB geht), genau deswegen ist es beim Multiboot auch nicht so einfach zu entscheiden wo /MB_Images ohne Harddisk hin soll.

Und ja, solange man andere sticks verwendet stört sich die testerei nicht mit einem mormalen BA 4.5.7

Na ja ich denk mal im Urlaub drüber nach wie man das am besten lösen kann und Ihr könnt rausfinden wie die bootparameter sein müssen.

This post has been edited 2 time(s), it was last edited by gutemine: 15.07.2008 19:31.

15.07.2008 19:29
astraflo
User


images/avatars/avatar-5.gif

Registration Date: 22.12.2005
Posts: 214
Which box: DM900
External Storage: USB-Stick
Which Image: Gemini

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Habe noch 2 sachen probiert:

1. FAT des Sticks am PC formatiert. Dann wieder versucht ein BA Image zu booten. Hat auch nix gebracht. Box bleibt weiterhin bei /usb/vmlinux.gz stehen ( WW 0.2.0-r3 + BA 4.58 ).

2. Multiboot 8.74 mit OoZooN im Flash probiert. Installation hat problemlos geklappt. Dann OoZooN auf den Stick kopiert u. siehe da: es geht. Mit den o.g. Bios-Einstellungen, d.h.:

Primary: usb /autorun.bat
Secondary: flash /autoexec.bat

USB Support: Enabled

Man muss die Box nicht anhalten u. auch sonst nicht zaubern. Multiboot läuft!

This post has been edited 2 time(s), it was last edited by astraflo: 15.07.2008 20:06.

15.07.2008 20:05 astraflo is offline Send an Email to astraflo Search for Posts by astraflo Add astraflo to your Buddy List
astraflo
User


images/avatars/avatar-5.gif

Registration Date: 22.12.2005
Posts: 214
Which box: DM900
External Storage: USB-Stick
Which Image: Gemini

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Jetzt bin ich allerdings mit Multiboot im USB-Image gefangen. Wenn ich wieder das Flash-Image zum Booten auswählen will, kommen Fehlermeldungen wie "cannot find /media/mb/flashbackup.tar.gz", irgendwas in /media/mb ist "not recoverable" usw. Ist da was nicht richtig verlinkt? Jedenfalls bootet er dann wieder das OoZooN vom Stick. Ins Flash komme ich mit Multiboot 8.74 nicht mehr zurück.

P.S. Scheinbar fehlt nur die Datei "flashbackup.tar.gz".

This post has been edited 4 time(s), it was last edited by astraflo: 15.07.2008 21:50.

15.07.2008 21:36 astraflo is offline Send an Email to astraflo Search for Posts by astraflo Add astraflo to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

sorry, das war noch ein überbleibsel des alten USB supports der 7025.

rm /mb/autorun.bat oder am PC löschen oder dort flashboot.bat ausführen und schon sollte wieder der Flash booten.

Dann lade dir aber den 8.74 kit von seite 6 hier im thread nochmals runter und mach ein update, mit dem sollte der bug jetzt gefixed sein, und ein multiboot.sh boot 0 oder boot F jetzt auch auf der 800er funktionieren.

Und auf der 1. Seite habe ich auch noch eine neue version des 4.5.8 BA kits gepostet, wo ich jetzt auch schweren Herzens das nachladen des FAT filesystems ins bainit eingebaut habe, damit sollte theoretisch auch das Gemini 3.6 wieder mit WW funktionieren selbst wenn es im Flash ist, ohne das man die bootup patchen muss (beim Multiboot ist das aber weiter nötig sonst verliert man wenn man ein Gemini 3.6 bootet das Plugin weil das FAT nicht gemountet werden kann)

Bitte alles testen und berichten, weil ab Donnerstag müsst Ihr Euch bis zum Urlaubsende selber helfen, heute ist also Eure letzte Chance alles zum laufen zu bringen, sonst müsst Ihr Euch in Geduld üben.

LG
gutemine

This post has been edited 5 time(s), it was last edited by gutemine: 16.07.2008 00:41.

16.07.2008 00:08
astraflo
User


images/avatars/avatar-5.gif

Registration Date: 22.12.2005
Posts: 214
Which box: DM900
External Storage: USB-Stick
Which Image: Gemini

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Danke für das Update. Jetzt geht Multiboot einwandfrei.

Zwischenfazit: Multiboot geht mit USB Support enabled im Bios, Barry Allen solo mit USB disabled (oder Stick kurz abziehen). BA mit WW muss ich noch probieren.

This post has been edited 1 time(s), it was last edited by astraflo: 16.07.2008 20:06.

16.07.2008 19:31 astraflo is offline Send an Email to astraflo Search for Posts by astraflo Add astraflo to your Buddy List
kddh
Newbie


images/avatars/avatar-2388.gif

Registration Date: 10.01.2005
Posts: 61
Which box: DM 7000S
External Storage: USB-Stick
Which Image: DMM original

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hallo, hier bin ich wieder :-)

Hatte am WE eine DM800 auf Booten vom USB 'umgerüstet'. (Händisch, d.h. ohne multiboot.sh).

Auf dem Stick haben wir das aktuelle Gemini 3.6 plazziert, und auch den Kernel von diesem:

Das ging nur mit Kernelparameter root=/dev/scsi/..../partN. Mit root=/dev/sdaN ging es nicht (blieb nach dem Kernellafden einfach stehen). Wie gesagt, mit Kernel von Gemini3.6 (hier im database).

PS: Von 9 Sticks gingen nur 2! War nur im RS232-Nulmodem-Terminal zu sehen, dass es am Stick liegt ("time out")
grx
kddh
16.07.2008 22:27 kddh is offline Send an Email to kddh Search for Posts by kddh Add kddh to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

na ja wenn Ihr meint es ist besser kann ich schon auch /dev/scsi... in die autorun,.bat vom Multiboot 8.74 reinmachen lassen, im prinzip ist es ja egal, hauptsache es funktioniert (besser).

Jetzt berichtet mal wie es um die tests beim WW + BA steht (den 4.5.8 kit habe ich noch ein bischen überarbeitet und in den normalen BA Thread gemoved) dann schaue ich mal das ich die kits am Wochenende fertig mache damit mit ich mich endlich der version 4.6 zuwenden kann mit dem 8000er support :-)

LG
gutemine

This post has been edited 1 time(s), it was last edited by gutemine: 25.07.2008 20:22.

25.07.2008 13:59
dreamedge dreamedge is a male
V.I.P.


images/avatars/avatar-19575.png

Registration Date: 28.03.2004
Posts: 534
Which box: DM900
External Storage: USB-Stick; SD-Card; HDD
Which accessories: Seagaste 2TB / sdcard 128GB
Which Image: OE 2.6
Welcher Bildschirm: Samsung LE37M87 BDX
Origin: NL

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

bin bis 11.08 in frankreich im urlaub ... aber vieleicht ist bis dahin ja die 8000er ja da ;-)

bin nur gerade mal im internetcafe :-)

__________________
Man muss das Unmögliche versuchen, um das Mögliche zu erreichen Hermann Hesse (1877-1962).
28.07.2008 15:55 dreamedge is offline Send an Email to dreamedge Homepage of dreamedge Search for Posts by dreamedge Add dreamedge to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Na ja dann schönen Urlaub !

Bitte testet mal ob WW 2.1 + BA 4.6.1 jetzt endlich auch mit der 800er funktioniert.

LG
gutemine
05.08.2008 13:18
dkleiber dkleiber is a male
Newbie


Registration Date: 13.03.2009
Posts: 1
Which box: DM 800C
External Storage: keine
Which Image: Sonstige

Wie test ich mein USB Stick? Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hey kann mir jemand helfen? wie teste ich mein usb stick bei der 800er?

Ich habe das ozzon instaliert, und möchte nun den Stick testen um zu schauen ob das gemini auf den Stick zu greifen kann...
24.04.2009 13:49 dkleiber is offline Send an Email to dkleiber Search for Posts by dkleiber Add dkleiber to your Buddy List
SiennaRoot SiennaRoot is a male
V.I.P.


images/avatars/avatar-19338.gif

Registration Date: 19.12.2006
Posts: 4,644
Which box: keine
External Storage: keine
Which Image: siehe Signatur
Welcher Bildschirm: 40'' LCD Toshiba 40ZF355D
Origin: aus dem Pott :-)

RE: Wie test ich mein USB Stick? Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

quote:
Original von dkleiber
Hey kann mir jemand helfen? wie teste ich mein usb stick bei der 800er?

Ich habe das ozzon instaliert, und möchte nun den Stick testen um zu schauen ob das gemini auf den Stick zu greifen kann...


Was ist das Problem ?

hast du schon BA installiert, mit / ohne WW , GP2 auf dem Stick installiert ?

wird der Stick nicht erkannt ?

__________________
QNAP TS-209 Pro, TS-409U, TS-219P

HD-Skins DMConcinnity-HD SR-MOD (OE2.0)

SiennaRoot's Home Picons Astra 19.2
24.04.2009 13:59 SiennaRoot is offline Send an Email to SiennaRoot Search for Posts by SiennaRoot Add SiennaRoot to your Buddy List
Pages (12): « first ... « previous 10 11 [12] Tree Structure | Board Structure
Jump to:
Post New Thread Post Reply
i-have-a-dreambox.com | Dreambox - Support » ...::: Archiv - Support für ältere Dreambox Modelle :::... » ...::: Dreambox und Images DM800 :::... » Allgemeines zur DM800 » Ja, die 800er kann auch komplett von USB booten

Privacy policy | Team | Suchen | Hilfe


Powered by Burning Board 2.3.6 © 2001-2003 WoltLab GbR