i-have-a-dreambox.com | Dreambox - Support

Register Calendar Members List Team Members Galerie to Portal Go to the Main Page

Boardrules Frequently Asked Questions Statistik Statistik Search Pinwand Dreambox Blog Ihad/Gemini Fan-Shop
i-have-a-dreambox.com | Dreambox - Support » ...::: Archiv - Support für ältere Dreambox Modelle :::... » ...::: Dreambox und Images DM800 :::... » Allgemeines zur DM800 » Image aufspielen + USB » Hello Guest [Login|Register]
Last Post | First Unread Post Print Page | Add Thread to Favorites
Pages (12): « previous 1 2 [3] 4 5 next » ... last » Post New Thread Post Reply
Go to the bottom of this page Image aufspielen + USB
Author
Post « Previous Thread | Next Thread »
macbeth
User


images/avatars/avatar-9997.gif

Registration Date: 24.06.2006
Posts: 183
Which box: DM 100S; DM 500S; DM 7025+SS; DM 8000HD
External Storage: HDD; CF; NFS
Which Image: Gemini
Welcher Bildschirm: Panasonic TH42-PV500E
Origin: Köln am Rhein

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Ich habe den ganzen Abend zum Testen, also Gemach Augenzwinkern
10.05.2008 18:46 macbeth is offline Send an Email to macbeth Search for Posts by macbeth Add macbeth to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

OK,ich denke wir müssen wieder einen Schritt zurück. Formatiere mal den stick am PC, dann steck Ihn an Die 800er und lade dir den 4.4.10 kit nochmals runtern. Und dann bitte OHNE Treiber vorher laden das ipk installierne und berichten ob der kit sich trotzdem richtig auf USB installiert (treiber werden vom ipk geladen), und ob der stick nach reboot auch noch auf/media/usb gemountet ist, bzw. ob das /dev/scsi nachher wieder weg ist.

LG
gutemine
10.05.2008 18:54
TexanerX TexanerX is a male
V.I.P.


images/avatars/avatar-8153.jpg

Registration Date: 29.03.2004
Posts: 941
External Storage: USB-Stick; HDD; NFS
Which accessories: Panasonic PT-AE3000 Beamer, DVDO VP30 Scaler
Which Image: Gemini; LT
Welcher Bildschirm: 46" Philips LED TV 46PFL9705K
Origin: Hessen

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Moin,

so siehts aus bei mir:

root@dm800:/tmp# ipkg install enigma2-plugin-extensions-barryallen_4.4.10_mipsel .ipk
Installing enigma2-plugin-extensions-barryallen (4.4.10) to root...
It's a Dream !
Only Harddisk found installing there !
Configuring enigma2-plugin-extensions-barryallen
Putting Barry Allen into Flash
/MB_Images will be created on /media/hdd/MB_Images
Integrating Barry Allen into WebIF
Flash Kernel Version: 2.6.12
keep squashfs for OE 1.5 images enabled
Restarting enigma to get Barry Allen V4.4.10 on HDD into Plugin List

Tex
10.05.2008 18:56 TexanerX is offline Send an Email to TexanerX Search for Posts by TexanerX Add TexanerX to your Buddy List
TexanerX TexanerX is a male
V.I.P.


images/avatars/avatar-8153.jpg

Registration Date: 29.03.2004
Posts: 941
External Storage: USB-Stick; HDD; NFS
Which accessories: Panasonic PT-AE3000 Beamer, DVDO VP30 Scaler
Which Image: Gemini; LT
Welcher Bildschirm: 46" Philips LED TV 46PFL9705K
Origin: Hessen

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

So, Stick nochmal neu formatiert:

root@dm800:/tmp# ipkg install enigma2-plugin-extensions-barryallen_4.4.10_mipsel.ipk
Installing enigma2-plugin-extensions-barryallen (4.4.10) to root...
It's a Dream !
USB Stick found installing Barry Allen there !
Erasing USB Stick ...
Making empty ext3 Filesystem ...
USB Stick mount added to /etc/fstab
Configuring enigma2-plugin-extensions-barryallen
Putting Barry Allen into Flash
/MB_Images will be created on /media/hdd/MB_Images
Integrating Barry Allen into WebIF
Flash Kernel Version: 2.6.12
keep squashfs for OE 1.5 images enabled
Restarting enigma to get Barry Allen V4.4.10 on USB into Plugin List

Tex
10.05.2008 19:05 TexanerX is offline Send an Email to TexanerX Search for Posts by TexanerX Add TexanerX to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

schlecht, also erstmals BA wieder von der Harddisk entfernen:

ipkg remove enigma2-plugin-extensions-barryallen

dann nochmal die Version 4.4.10 runterladen (habs grade ausgetauscht)

Und damit nach reboot nochmals probieren ob er damit dann USB stick genommen wird ohne das Ihr die USB treiber laden müsst.

Und dann rebooten und schauen ob der stick kauf /dev/scsi auftaucht OHNE das man Treiber selber laden muss und ob der stick auf /media/usb auch nach reboot gemountet ist (mount eingeben oder df -h)

solange das nicht funzt kann man auch nicht davon booten :-(

This post has been edited 3 time(s), it was last edited by gutemine: 10.05.2008 19:10.

10.05.2008 19:07
TexanerX TexanerX is a male
V.I.P.


images/avatars/avatar-8153.jpg

Registration Date: 29.03.2004
Posts: 941
External Storage: USB-Stick; HDD; NFS
Which accessories: Panasonic PT-AE3000 Beamer, DVDO VP30 Scaler
Which Image: Gemini; LT
Welcher Bildschirm: 46" Philips LED TV 46PFL9705K
Origin: Hessen

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Alles ok. So siehts aus:

root@dm800:/tmp# cd /mnt/usb
root@dm800:/media/usb# ls
BarryAllen bainit barryallen.mvi bin script
ba bapostinst.template barryallen_dark.mvi locale usr
ba.sh barryallen.bmp barryallen_standard.mvi lost+found
root@dm800:/media/usb#


Werde jetzt mal versuchen ein image zu entpacken.

Tex
10.05.2008 19:09 TexanerX is offline Send an Email to TexanerX Search for Posts by TexanerX Add TexanerX to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

ja, wenn nach einem reboot der stick wieder da ist darfst du ein image von /MB_Images auspacken und schauen ob es im bootmanager auch angezeigt wird

ABER dazu nicht gleich beim booten sondern nach dem auspacken des images erstmals bei laufendem image das bootmenu starten:

init 4
bainit

und berichten ob dabei Bootmenu am screen kommt. Wenn ja rebooten und berichten ob es auch bei reboot zur auswahl kommt - wenn nicht bitte den inhalt vom .balog von gleich nach dem reboot posten:

cat /ba/.balog

This post has been edited 4 time(s), it was last edited by gutemine: 10.05.2008 19:15.

10.05.2008 19:12
TexanerX TexanerX is a male
V.I.P.


images/avatars/avatar-8153.jpg

Registration Date: 29.03.2004
Posts: 941
External Storage: USB-Stick; HDD; NFS
Which accessories: Panasonic PT-AE3000 Beamer, DVDO VP30 Scaler
Which Image: Gemini; LT
Welcher Bildschirm: 46" Philips LED TV 46PFL9705K
Origin: Hessen

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Sorry, BA Startscreen wird nicht angezeigt. Nach dem reboot ist USB Stick inaktiv.

/sbin/init: 221: /media/ba/bin/barryallen: not found

Tex

This post has been edited 1 time(s), it was last edited by TexanerX: 10.05.2008 19:17.

10.05.2008 19:17 TexanerX is offline Send an Email to TexanerX Search for Posts by TexanerX Add TexanerX to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

und wenn du nach reboot von hand mountest:

modprobe sd_mod
modprobe usb-storage

10 sec warten

mount /media/usb

Wird der stick dann gemountent und kommt das bootemenu wenigstens so:

init 4
bainit

wenn nicht bitte nochmals output von /ba/.balog posten !

This post has been edited 2 time(s), it was last edited by gutemine: 10.05.2008 19:22.

10.05.2008 19:19
TexanerX TexanerX is a male
V.I.P.


images/avatars/avatar-8153.jpg

Registration Date: 29.03.2004
Posts: 941
External Storage: USB-Stick; HDD; NFS
Which accessories: Panasonic PT-AE3000 Beamer, DVDO VP30 Scaler
Which Image: Gemini; LT
Welcher Bildschirm: 46" Philips LED TV 46PFL9705K
Origin: Hessen

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

root@dm800:~# modprobe sd_mod
root@dm800:~# modprobe usb-storage
insmod: cannot insert `/lib/modules/2.6.12-5.1-brcmstb-dm800/kernel/drivers/usb/storage/usb-stora
ge.ko': File exists (-1): File exists
modprobe: failed to load module usb-storage
root@dm800:~# mount /media/usb
mount: Mounting /dev/scsi/host1/bus0/target0/lun0/part1 on /media/usb failed: No such file or directory
root@dm800:~#


root@dm800:~# init 4
root@dm800:~# bainit
umount: /media/usb: Invalid argument
/media/ba/barryallen.mvi: No such file or directory
init is called during boot without parameters
therefore starting barryallen bootmanager
Usage: init.sysvinit 0123456SsQqAaBbCcUu
root@dm800:~#

This post has been edited 1 time(s), it was last edited by TexanerX: 10.05.2008 19:24.

10.05.2008 19:22 TexanerX is offline Send an Email to TexanerX Search for Posts by TexanerX Add TexanerX to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

auch die 10 sec gewartet damit das device auf /dev/scsi zeit hat erstellt zu werden ?

steht im output von dmesg das der stick erkannt wurde ?

This post has been edited 1 time(s), it was last edited by gutemine: 10.05.2008 19:24.

10.05.2008 19:24
macbeth
User


images/avatars/avatar-9997.gif

Registration Date: 24.06.2006
Posts: 183
Which box: DM 100S; DM 500S; DM 7025+SS; DM 8000HD
External Storage: HDD; CF; NFS
Which Image: Gemini
Welcher Bildschirm: Panasonic TH42-PV500E
Origin: Köln am Rhein

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Auch mit dem neuen BA 4.4.10 ist der USB-Stick nach dem Reboot weg. Das Mountskript für den USB passt nicht, weil da die Device falsch ist bzw. ich den Stick im falschen USB-Port habe. Wenn ich es händisch nach /media/usb mounte kann ich mit "init4" und "bainit" das Bootmeü aufrufen.
10.05.2008 19:24 macbeth is offline Send an Email to macbeth Search for Posts by macbeth Add macbeth to your Buddy List
TexanerX TexanerX is a male
V.I.P.


images/avatars/avatar-8153.jpg

Registration Date: 29.03.2004
Posts: 941
External Storage: USB-Stick; HDD; NFS
Which accessories: Panasonic PT-AE3000 Beamer, DVDO VP30 Scaler
Which Image: Gemini; LT
Welcher Bildschirm: 46" Philips LED TV 46PFL9705K
Origin: Hessen

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

root@dm800:~# find /dev/scsi
/dev/scsi

SCSI subsystem initialized
Initializing USB Mass Storage driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered.



Das ist ja da

Tex

This post has been edited 1 time(s), it was last edited by TexanerX: 10.05.2008 19:26.

10.05.2008 19:25 TexanerX is offline Send an Email to TexanerX Search for Posts by TexanerX Add TexanerX to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

OK, dann ist noch ein Fehler im device handling - ich musste es ja ein bischen umbauen damit beide USB ports funktionieren. Wobei eigentlich auch der stick erkannt werden müsste und sich im dmesg verewigen

postet mal den output von /dev/scsi um zu sehen welche devices ihr habt und ob die nach reboot und neuerlichem driver load die selben sind

weil eigentlich müßte das find folgenden output liefern:

root@dm7025:/media/cf# find /dev/scsi
/dev/scsi
/dev/scsi/host0
/dev/scsi/host0/bus0
/dev/scsi/host0/bus0/target0
/dev/scsi/host0/bus0/target0/lun0
/dev/scsi/host0/bus0/target0/lun0/disc
/dev/scsi/host0/bus0/target0/lun0/part1

This post has been edited 2 time(s), it was last edited by gutemine: 10.05.2008 19:28.

10.05.2008 19:26
macbeth
User


images/avatars/avatar-9997.gif

Registration Date: 24.06.2006
Posts: 183
Which box: DM 100S; DM 500S; DM 7025+SS; DM 8000HD
External Storage: HDD; CF; NFS
Which Image: Gemini
Welcher Bildschirm: Panasonic TH42-PV500E
Origin: Köln am Rhein

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

root@dm800:~# mount /media/usb
mount: Mounting /dev/scsi/host1/bus0/target0/lun0/part1 on /media/usb failed: No such file or directory

Händisch klappts dann:


root@dm800:~# mount /dev/scsi/host0/bus0/target0/lun0/part1 /media/usb
10.05.2008 19:27 macbeth is offline Send an Email to macbeth Search for Posts by macbeth Add macbeth to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

danke, also falsch 1x host0 und dann host1 - was schlecht ist :-(

mals sehen wie ich das fixen kann

Bzw. kann es sein das du stick an und abgesteckt hast - weil dann wird er mit neuer host1 wieder angelegt.

Probier mal die /etc/fstab entsprechend editieren das sie zum device passt - schafft Ihr das ?

This post has been edited 1 time(s), it was last edited by gutemine: 10.05.2008 19:31.

10.05.2008 19:29
macbeth
User


images/avatars/avatar-9997.gif

Registration Date: 24.06.2006
Posts: 183
Which box: DM 100S; DM 500S; DM 7025+SS; DM 8000HD
External Storage: HDD; CF; NFS
Which Image: Gemini
Welcher Bildschirm: Panasonic TH42-PV500E
Origin: Köln am Rhein

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Ich hab gerade mal den Stick vom unteren USB Port in den oberen gesteckt, dann gibt das

/dev/scsi/host1/bus0/target0/lun0/part1


Wenn Du das einfach auf einen der beiden Pfade anpasst und dann sagst: "Nur im unteren USB Port nutzen" oder so?


EDIT: Nach intensiverem Nachdenken habe ich selbst erkannt, was das für ein Schwachsinn war, den ich geschrieben habe.

This post has been edited 1 time(s), it was last edited by macbeth: 10.05.2008 19:39.

10.05.2008 19:33 macbeth is offline Send an Email to macbeth Search for Posts by macbeth Add macbeth to your Buddy List
TexanerX TexanerX is a male
V.I.P.


images/avatars/avatar-8153.jpg

Registration Date: 29.03.2004
Posts: 941
External Storage: USB-Stick; HDD; NFS
Which accessories: Panasonic PT-AE3000 Beamer, DVDO VP30 Scaler
Which Image: Gemini; LT
Welcher Bildschirm: 46" Philips LED TV 46PFL9705K
Origin: Hessen

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

rootfs / auto defaults 1 1
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
usbdevfs /proc/bus/usb usbfs defaults 0 0
/dev/mtdblock/2 /boot jffs2 ro 0 0
tmpfs /var tmpfs defaults 0 0
tmpfs /tmp tmpfs defaults 0 0
/dev/ide/host0/bus0/target0/lun0/part1 /media/hdd auto defaults 0 0
/dev/scsi/host1/bus0/target0/lun0/part1 /media/usb auto defaults 0 0

So sieht die aus. Bei mir ist nach dem Reboot :


root@dm800:~# find /dev/scsi
find: /dev/scsi: No such file or directory

Tex
10.05.2008 19:35 TexanerX is offline Send an Email to TexanerX Search for Posts by TexanerX Add TexanerX to your Buddy List
gutemine
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Na ja, lieber wäre es mir schon wen BA auf beiden USB Anschlüssen gehen würde - bei der 7025+ gehts ja auch auf dem externen und dem interen USB Anschluss.

Sobalddas mounten von /media/usb im /etc/fstab steht darf man den stick eh nicht mehr umstecken.

Aber jetzt muss es erstmal stabil installieren gehen und nach reboot immer noch da sein (selbst wenn man die Treiber noch von hand laden muss sollte er zum Eintrag in /etc/fstab passen !)

Also einen neuen Kit 4.4.10 habe ich noch gemacht, bitte nochmals runterladen und drüber installieren und berichten ob doie BA installation wieder ohne Treiber laden auf USB stick geht und was nach einem reboot passiert. Stick gemountet, oder gemountet erst nach driverload und mount /media/usb , oder schon wieder falsches device in der /etc/fstab :-()

Und falls schon wieder falsches device evt nochmals rebooten und schauen ob das /dev/scsi/hostX wieder ein anders X hat - weil dann müssten wir uns bei DMM wieder beschweren so wie damals auf der 7025+ die hatte das auch das das device beim rebooten hochgezählt hat - was das booten recht schwierig macht - aber nicht unmöglich, keine Angst ,so leicht gehe ich nicht auf :-)

This post has been edited 1 time(s), it was last edited by gutemine: 10.05.2008 19:48.

10.05.2008 19:45
macbeth
User


images/avatars/avatar-9997.gif

Registration Date: 24.06.2006
Posts: 183
Which box: DM 100S; DM 500S; DM 7025+SS; DM 8000HD
External Storage: HDD; CF; NFS
Which Image: Gemini
Welcher Bildschirm: Panasonic TH42-PV500E
Origin: Köln am Rhein

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Alles klar, bin schon dran. Ich mache das neue BA per ipkg immer erst mit remove weg, boote dann neu und dann mit install das neue drauf. Das ist vermutlich zu umständlich? smile

This post has been edited 1 time(s), it was last edited by macbeth: 10.05.2008 19:52.

10.05.2008 19:48 macbeth is offline Send an Email to macbeth Search for Posts by macbeth Add macbeth to your Buddy List
Pages (12): « previous 1 2 [3] 4 5 next » ... last » Tree Structure | Board Structure
Jump to:
Post New Thread Post Reply
i-have-a-dreambox.com | Dreambox - Support » ...::: Archiv - Support für ältere Dreambox Modelle :::... » ...::: Dreambox und Images DM800 :::... » Allgemeines zur DM800 » Image aufspielen + USB

Privacy policy | Team | Suchen | Hilfe


Powered by Burning Board 2.3.6 © 2001-2003 WoltLab GbR