i-have-a-dreambox.com | Dreambox - Support

Register Calendar Members List Team Members Galerie to Portal Go to the Main Page

Boardrules Frequently Asked Questions Statistik Statistik Search Pinwand Dreambox Blog Ihad/Gemini Fan-Shop
i-have-a-dreambox.com | Dreambox - Support » ...::: Dreambox Software :::... » Dreambox Kodi (DreamOS) » Kodi install bash script » Hello Guest [Login|Register]
Last Post | First Unread Post Print Page | Add Thread to Favorites
Post New Thread Post Reply
Go to the bottom of this page Kodi install bash script
Author
Post « Previous Thread | Next Thread »
audi06_19 audi06_19 is a male
Newbie


Registration Date: 08.04.2015
Posts: 22
Which box: DM900
External Storage: HDD
Which Image: OE 2.5

Kodi install bash script Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Kodi MediaCenter Install

zip extract
Throw in tmp
give the authorities

code:
1:
2:
3:
4:
dos2unix /tmp/KodiMediaCenter_Install.sh
chmod 777 /tmp/KodiMediaCenter_Install.sh


Run Start 1 2 3
code:
1:
bash /tmp/KodiMediaCenter_Install.sh


http://depo.dreamosat.net/Tools/KodiMedi..._Install.sh.zip

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
#!/bin/bash
# Coded by audi06_19 (c) (®) (©) 2018
FIN="=================================================="
echo $FIN
echo ".....:: LÜTFEN BEKLEY0N0Z .... PLEASE WAIT ::....."
sleep 1;
echo $FIN
set -e
cd /tmp
kodi=$(opkg list-installed kodi | awk '{ print $1 }')
g3wizard=$(opkg list-installed g3wizard | awk '{ print $1 }')

if [ "$g3wizard" = "g3wizard" ]; then
  echo "g3wizard yüklü tekrar yüklenmesine gerek yok ..."
  echo $FIN
  if [ -f /etc/apt/sources.list.d/gemini33-unstable-all-feed.list ] ; then
    if [ "$kodi" = "kodi" ]; then
      echo "kodi yüklü, tekrar yüklenmesine gerek yok ..."
      echo $FIN
    else
      echo "Kodi ISNTALL EDILIYOR ..."
      echo $FIN
      echo "Update, Upgrade Güncelleme yap1l1yor"
      echo $FIN
      apt-get update > /dev/null;
      apt-get upgrade > /dev/null;
      apt-get -f --force-yes --assume-yes install
      #
      echo "Download lib"
      echo $FIN
      apt-get install --yes --force-yes --assume-yes gstreamer1.0-plugins-base-apps gdb glibc-charmap-ibm850 glibc-gconv-utf-32 glibc-localedata-en-us python-shell python python-json python-html python-ctypes python-difflib glibc-gconv-ibm850 glibc-gconv-unicode libcurl4 python-compression python-zlib python-sqlite3 python-re python-lang python-netclient glibc-charmap-utf-8

      apt-get install --yes --force-yes --assume-yes libswscale4 libpostproc54 libavfilter6
      apt-get install --yes --force-yes --assume-yes kernel-module-cdc-acm
      echo $FIN
      echo "Fix"
      apt-get -f --force-yes --assume-yes install
      echo $FIN
      echo "Download lib"
      apt-get install --yes --force-yes --assume-yes lcms
      apt-get install --yes --force-yes --assume-yes libtiff5
      apt-get install --yes --force-yes --assume-yes libsmbclient0
      apt-get install --yes --force-yes --assume-yes libpcrecpp0
      apt-get install --yes --force-yes --assume-yes liblzo2-2
      apt-get install --yes --force-yes --assume-yes libgcrypt
      apt-get install --yes --force-yes --assume-yes libgpg-error0
      apt-get install --yes --force-yes --assume-yes libtag1
      apt-get install --yes --force-yes --assume-yes libmysqlclient18
      #apt-get install --yes --force-yes --assume-yes libnfs1
      apt-get install --yes --force-yes --assume-yes libssh
      apt-get install --yes --force-yes --assume-yes libtinyxml2.6.2
      apt-get install --yes --force-yes --assume-yes libyajl2
      apt-get install --yes --force-yes --assume-yes gstreamer1.0-libav
      apt-get install --yes --force-yes --assume-yes libmicrohttpd10
      #
      echo "Fix"
      echo $FIN
      apt-get -f --force-yes --assume-yes install
      #
      echo "Download Kodi install"
      echo $FIN
      apt-get install --yes --force-yes --assume-yes kodi
      apt-get -f --force-yes --assume-yes install
      #
      echo "Download libkodiplatform17.0 install"
      echo $FIN
      apt-get install --yes --force-yes --assume-yes libkodiplatform17.0
      apt-get -f --force-yes --assume-yes install
      #
      echo "Kodi enigma2-plugin-extensions-kodimediacenter install"
      echo $FIN
      apt-get install --yes --force-yes --assume-yes enigma2-plugin-extensions-kodimediacenter
      apt-get -f --force-yes --assume-yes install
      #
#      echo "kodi pvr-vuplus install"
#      echo $FIN
#      apt-get install --yes --force-yes --assume-yes kodi-addon-pvr-vuplus
#      apt-get -f --force-yes --assume-yes install
      #
#      echo "Fix"
#      echo $FIN
#      apt-get install --yes --force-yes --assume-yes kodi-addon-pvr-iptvsimple
#      apt-get -f --force-yes --assume-yes install
      #
#      echo "Kodi kodidisplayinfo install"
#      echo $FIN
#      apt-get install --yes --force-yes --assume-yes kodidisplayinfo
#      apt-get -f --force-yes --assume-yes install
      #
#      killall -9 enigma2
    fi
  else
    echo "Kumandan1z1n mavi tu_una bas1n1z ve g3wizard kurulum gerçekle_tiriniz."
    echo "Sonra tekrar DreamOSat Script çal1_t1r1n."
    echo $FIN
  fi
else
  echo "Update, Upgrade Güncelleme yap1l1yor "
  echo $FIN
  apt-get update > /dev/null;
  apt-get upgrade > /dev/null;
  echo "g3wizard"
  echo $FIN
  curl -OLk http://download.blue-panel.com/gemini33/g3wizard_2.3-r0.0_all.deb
  dpkg -i /tmp/g3wizard_2.3-r0.0_all.deb
  echo "Fix"
  echo $FIN
  apt-get -f --force-yes --assume-yes install
  echo "PLEASE RESTART YOUR STB"
  killall -9 enigma2
fi
set +e
cd /
sync
echo ""
echo " G3wizard, Kodi,"
echo "DreamOS 2.5 - DM900 / DM920, DM820 / DM7080";
echo ""
echo "###### Thank you, Danke, By. emanuel, pclin";
echo "===========================================";
echo "           ..:: A U T H O R ::..           ";
echo "              << audi06_19 >>              ";
echo "===========================================";
sleep 3;
exit 0 

This post has been edited 1 time(s), it was last edited by audi06_19: 15.04.2018 12:19.

15.04.2018 12:19 audi06_19 is offline Send an Email to audi06_19 Search for Posts by audi06_19 Add audi06_19 to your Buddy List
pclin
unregistered
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hi,
RESTART YOUR STB with
code:
1:
systemctl restart enigma2

TOP like

gruß pclin

This post has been edited 2 time(s), it was last edited by pclin: 15.04.2018 12:56.

15.04.2018 12:52
audi06_19 audi06_19 is a male
Newbie


Registration Date: 08.04.2015
Posts: 22
Which box: DM900
External Storage: HDD
Which Image: OE 2.5

Thread Starter Thread Started by audi06_19
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Kodi 18 MediaCenter Install

Throw in tmp
give the authorities

code:
1:
2:
3:
4:
dos2unix /tmp/Kodi-18_MediaCenter_Install.sh
chmod 777 /tmp/Kodi-18_MediaCenter_Install.sh
# Run Start
bash /tmp/Kodi-18_MediaCenter_Install.sh


code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
#!/bin/bash
# Coded by audi06_19 (c) (®) (©) 2019
FIN="=================================================="
echo $FIN
echo ".....:: LÜTFEN BEKLEY0N0Z .... PLEASE WAIT ::....."
sleep 1;
echo $FIN
set -e
cd /tmp
kodi=$(opkg list-installed kodi | awk '{ print $1 }')
if [ "$kodi" = "kodi" ]; then
      echo "kodi yüklü, tekrar yüklenmesine gerek yok ..."
      echo "kodi installed, no need to install again ..."
      echo $FIN
else
#--------------------
uname -m > /tmp/DreamOSat/name.txt
if grep -qs 'mips' cat /tmp/DreamOSat/name.txt ; then
cat > /etc/apt/sources.list.d/kodi-18-unstable-mipsel-feed.list << EOF
deb http://download.blue-panel.com/krogoth/kodi-18/mipsel ./
EOF
elif grep -qs "armv7l" cat /tmp/DreamOSat/name.txt ; then
cat > /etc/apt/sources.list.d/kodi-18-unstable-armhf-feed.list << EOF
deb http://download.blue-panel.com/krogoth/kodi-18/armhf ./
EOF
else
echo $FIN
echo 'Üzgünüm, cihaz1n1za uygun Kodi yok :('
echo 'Sorry, your device does not have the proper Kodi :('
exit 1;
fi
#-- remove pluginsort --
pluginsort=$(opkg list-installed enigma2-plugin-extensions-pluginsort | awk '{ print $1 }')
      if [ "$pluginsort" = "enigma2-plugin-extensions-pluginsort" ]; then
         apt-get  purge --auto-remove --force-yes --assume-yes enigma2-plugin-extensions-pluginsort
         echo "PluginSort Remove"
      fi
#-- remove MenuSort --
menusort=$(opkg list-installed enigma2-plugin-extensions-menusort | awk '{ print $1 }')
      if [ "$menusort" = "enigma2-plugin-extensions-pluginsort" ]; then
         apt-get  purge --auto-remove --force-yes --assume-yes enigma2-plugin-extensions-menusort
         echo "MenuSort Remove"
      fi
      echo "System Update, Upgrade"
      echo $FIN
      apt-get update > /dev/null;
      apt-get upgrade > /dev/null;
      apt-get -f --force-yes --assume-yes install
      #
      echo "Download Kodi install"
      echo $FIN
      apt-get install --yes --force-yes --assume-yes kodi
      apt-get -f --force-yes --assume-yes install
      #
      echo "Kodi MediaCenter install"
      echo $FIN
      apt-get install --yes --force-yes --assume-yes enigma2-plugin-extensions-kodimediacenter
      apt-get -f --force-yes --assume-yes install
      #
      echo "system restart gui"
      sleep 3;
      systemctl restart enigma2.service
fi
set +e
cd /
sync
echo ""
echo "DreamOS 2.5 - DM900 / DM920, DM820 / DM7080";
echo ""
echo "Thank you, By.emanuel www.i-have-a-dreambox.com";

exit 0 


Attachment:
unknown Kodi-18_MediaCenter_Install.sh (2.41 KB, 59 downloads)
17.02.2019 23:03 audi06_19 is offline Send an Email to audi06_19 Search for Posts by audi06_19 Add audi06_19 to your Buddy List
mecky76 mecky76 is a male
Newbie


Registration Date: 10.03.2019
Posts: 2
Which box: DM900
External Storage: HDD
Which Image: OE 2.5

Kodi Install bash Problem Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hallo,

ich habe eine DM900 newnigma2 OE2,5 dm900 9.03.2019.

Beim Ausführen hatte ich eine Fehler in Zeile 17. durch den Ordner DreamOSat mit name.txt konnte ich das Script starten


Der Fehler mit "No PUBKEY" kann ich vernachlässigen ?

Wie bekomme ich die Python Version von 1.1 auf 1.7 was Kodi möchte ?



mfg mecky76

System Update, Upgrade
==================================================
W: GPG error: http://download.blue-panel.com ./ Release: The following signatures couldn't be verified because th e public key is not available: NO_PUBKEY E7CE1D14D5EA8D10

This post has been edited 2 time(s), it was last edited by mecky76: 11.03.2019 14:53.

11.03.2019 14:44 mecky76 is offline Send an Email to mecky76 Search for Posts by mecky76 Add mecky76 to your Buddy List
mecky76 mecky76 is a male
Newbie


Registration Date: 10.03.2019
Posts: 2
Which box: DM900
External Storage: HDD
Which Image: OE 2.5

Python 1.71 Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hallo

Wie kann ich die Abhängigkeiten installieren ?

Das Paket habe ich gefunden und soweit installiert
python-cryptography_1.7.13_armhf.deb

"python-cryptography:
Installed: 1.7.1-3
Candidate: 1.7.1-3"



You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
python-cryptography : Depends: python (< 2.cool
Depends: python (>= 2.7~)
Depends: python-cffi-backend-api-min (<= 9729) but it is not installable
Depends: python-cffi-backend-api-max (>= 9729) but it is not installable
Depends: python:any (< 2.cool but it is not installable
Depends: python:any (>= 2.7.5-5~) but it is not installable
Depends: libssl1.1 (>= 1.1.0) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
12.03.2019 22:48 mecky76 is offline Send an Email to mecky76 Search for Posts by mecky76 Add mecky76 to your Buddy List
Tree Structure | Board Structure
Jump to:
Post New Thread Post Reply
i-have-a-dreambox.com | Dreambox - Support » ...::: Dreambox Software :::... » Dreambox Kodi (DreamOS) » Kodi install bash script

Privacy policy | Team | Suchen | Hilfe


Powered by Burning Board 2.3.6 © 2001-2003 WoltLab GbR