i-have-a-dreambox.com | Dreambox - Support

Register Calendar Members List Team Members Galerie to Portal Go to the Main Page

Boardrules Frequently Asked Questions Statistik Statistik Search Pinwand Dreambox Blog Ihad/Gemini Fan-Shop
i-have-a-dreambox.com | Dreambox - Support » ...::: Archiv - Support für ältere Dreambox Modelle :::... » ...::: Dreambox und Images DM 600PVR :::... » CVS Images Enigma2 DM600PVR » Cable scan problem with the Pcd 3.1 enigma2 image » Hello Guest [Login|Register]
Last Post | First Unread Post Print Page | Add Thread to Favorites
Post New Thread Post Reply
Go to the bottom of this page Cable scan problem with the Pcd 3.1 enigma2 image
Author
Post « Previous Thread | Next Thread »
pcd pcd is a male
V.I.P.


Registration Date: 31.08.2004
Posts: 3,990
Which box: siehe Signatur
External Storage: NFS
Which Image: Sonstige
Origin: UK

Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hi,

@elmartino wrote :-

" hans753 solved the scanning issue:
"The scan seems to work if you change the scanning method.
It seems to work this way: Tuner Configuration. In German "Typ der Kanalsuche" Set it to Provider."

Yesterday I updated to 3.1 (even if I was happy with 2.2...) and it works just great.

Of course some steps are required with an attached NAS:
- update with new image
- I deleted via ftp the smbd file
- In mount manager I added my NAS
- reboot
- increase memory (hdd)
- scan chanels
- install software

I found only one issue: somehow the webinterface seems to be updated. This results in Firefox to strange messages at the TeleVision tab (ERROR: ReferenceError). After searching in the forum I found out, that you have to clear the Firefox cache. I do not have Gears installed.

Also I saw that now upnp-related packages are offered. Only I could not find an app using it. Did I miss something?

Now everything works fine :-)"

Then @hans753 wrote :

"Today I installed the new version, too. I can confirm that the problem still exists on the DM600 PVR-C
I tried to fix the bug, but it didn't work.
The problem is located in the file /usr/lib/enigma2/python/Screens/ScanSetup.py in line 161, the problem (IndexError: list index out of range)
This line causes the problem
tmpstr += data[1]

The problem is, that data[1] doesn't contain any data.
It seems like data, doesn't contain any data at all."

Will it be ok if - in the next image - I remove the possibility of crash ? You can still do cable scan using the "Provider" option ?

Cheers, pcd.

This post has been edited 2 time(s), it was last edited by pcd: 03.11.2010 11:26.

03.11.2010 11:24 pcd is offline Send an Email to pcd Search for Posts by pcd Add pcd to your Buddy List
taitlth
Newbie


Registration Date: 26.04.2007
Posts: 11
Which box: DM 600PVR-S; andere
External Storage: HDD
Which Image: PLi; Sonstige
Welcher Bildschirm: Sharp Aquous 37"
Origin: A

RE: Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

with "Sendersuche mit Provider" I can not change Q64 to Q256 - and manual search does not variy the frequencey.
Does anyone know, where I can find the configuration for the "Proider search"?

Would help, because the provider changed from Q64 to Q256!

Until then the image worked really fine and the workaround did it.

Frequency search leads to green screen.

Has anyone a idea where to search for the configuration, that sets the serarch for provider?

thx

This post has been edited 1 time(s), it was last edited by taitlth: 08.11.2010 20:32.

04.11.2010 06:05 taitlth is offline Send an Email to taitlth Search for Posts by taitlth Add taitlth to your Buddy List
taitlth
Newbie


Registration Date: 26.04.2007
Posts: 11
Which box: DM 600PVR-S; andere
External Storage: HDD
Which Image: PLi; Sonstige
Welcher Bildschirm: Sharp Aquous 37"
Origin: A

RE: Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hi pcd,

you plan to fix the cable-scan in the next release.
Have you any idea, when that could be?

I cannot use the box until then with the image, and it ist the one and only.

Best regards Thomas
13.11.2010 07:42 taitlth is offline Send an Email to taitlth Search for Posts by taitlth Add taitlth to your Buddy List
pcd pcd is a male
V.I.P.


Registration Date: 31.08.2004
Posts: 3,990
Which box: siehe Signatur
External Storage: NFS
Which Image: Sonstige
Origin: UK

Thread Starter Thread Started by pcd
RE: Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hi,

I looked into this quickly - but did not have much time. Sorry !

ScanSetup.py has these lines :-

code:
1:
2:
3:
4:
5:
6:
7:
8:
			if data[0] == 'OK':
				print str
				parm = eDVBFrontendParametersCable()
				qam = { "QAM16" : parm.Modulation_QAM16,
					"QAM32" : parm.Modulation_QAM32,
					"QAM64" : parm.Modulation_QAM64,
					"QAM128" : parm.Modulation_QAM128,
					"QAM256" : parm.Modulation_QAM256 }


It seems - it allows QAM256. So - I do not know what the problem is.

What exacly do you see when you try to scan ?

Also, does your cable scan work with an enigma1 image ?

Please telnet these commands :

init 4
killall -9 enigma2
enigma2>/tmp/e.log 2>&1 &

Next - try to do a scan. Then post the file /tmp/e.log. You may pm to me this file.

Cheers, pcd.

This post has been edited 3 time(s), it was last edited by pcd: 13.11.2010 13:49.

13.11.2010 11:02 pcd is offline Send an Email to pcd Search for Posts by pcd Add pcd to your Buddy List
pcd pcd is a male
V.I.P.


Registration Date: 31.08.2004
Posts: 3,990
Which box: siehe Signatur
External Storage: NFS
Which Image: Sonstige
Origin: UK

Thread Starter Thread Started by pcd
RE: Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

quote:
Originally posted by taitlth
Hi pcd,

you plan to fix the cable-scan in the next release.
Have you any idea, when that could be?

I cannot use the box until then with the image, and it ist the one and only.

Best regards Thomas


Hi,

Please replace the file /usr/lib/enigma2/python/Screens/ScanSetup.py with the attached.

Restart enigma2. Then try to do a scan using the Provider workaround.

Cheers, pcd.

Attachment deleted -did not work.

This post has been edited 1 time(s), it was last edited by pcd: 21.11.2010 15:04.

18.11.2010 13:41 pcd is offline Send an Email to pcd Search for Posts by pcd Add pcd to your Buddy List
taitlth
Newbie


Registration Date: 26.04.2007
Posts: 11
Which box: DM 600PVR-S; andere
External Storage: HDD
Which Image: PLi; Sonstige
Welcher Bildschirm: Sharp Aquous 37"
Origin: A

RE: Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hi,

I tried your file - but the provider-scan only scans QAM64 and stopps with zero results.
Somewhere the configuration for provider scan has to be set - but I cant find it in the scan.py.

Can you see anything in the enclosed crashlog?

Thomas

Attachment:
unknown enigma2_crash_1086.log (43 KB, 10 downloads)

This post has been edited 1 time(s), it was last edited by taitlth: 20.11.2010 14:12.

20.11.2010 08:10 taitlth is offline Send an Email to taitlth Search for Posts by taitlth Add taitlth to your Buddy List
pcd pcd is a male
V.I.P.


Registration Date: 31.08.2004
Posts: 3,990
Which box: siehe Signatur
External Storage: NFS
Which Image: Sonstige
Origin: UK

Thread Starter Thread Started by pcd
RE: Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

quote:
Originally posted by taitlth
Hi,

I tried your file - but the provider-scan only scans QAM64 and stopps with zero results.
Somewhere the configuration for provider scan has to be set - but I cant find it in the scan.py.


You can try this :

In /usr/lib/enigma2/python/Components/NimManager.py - change ths line :-

code:
1:
nim.cable.scan_mod_qam64 = ConfigYesNo(default = True)


to :-

code:
1:
nim.cable.scan_mod_qam64 = ConfigYesNo(default = False)


and restart enigma2.

qam256 is already default=True.

Cheers, pcd.
20.11.2010 14:15 pcd is offline Send an Email to pcd Search for Posts by pcd Add pcd to your Buddy List
taitlth
Newbie


Registration Date: 26.04.2007
Posts: 11
Which box: DM 600PVR-S; andere
External Storage: HDD
Which Image: PLi; Sonstige
Welcher Bildschirm: Sharp Aquous 37"
Origin: A

RE: Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

I am afraid, that did'nt work.
The provider scan only scans QAM64.

But I found a workaround:
got the list of freqiemces from the provider and used the manual scan for the interesting frequencies.

Now it works!

Best regards

Thomas
23.11.2010 11:51 taitlth is offline Send an Email to taitlth Search for Posts by taitlth Add taitlth to your Buddy List
pcd pcd is a male
V.I.P.


Registration Date: 31.08.2004
Posts: 3,990
Which box: siehe Signatur
External Storage: NFS
Which Image: Sonstige
Origin: UK

Thread Starter Thread Started by pcd
RE: Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

quote:
Originally posted by taitlth
I am afraid, that did'nt work.
The provider scan only scans QAM64.

But I found a workaround:
got the list of freqiemces from the provider and used the manual scan for the interesting frequencies.

Now it works!

Best regards

Thomas


Did you try this before ?

I thought only 'Privider scan' was possible. Manual frequency scan gave a crash !

Please explain what works - as I do not have cable tuner. So I do not know what are manual scan settings.

Cheers, pcd.
23.11.2010 13:58 pcd is offline Send an Email to pcd Search for Posts by pcd Add pcd to your Buddy List
taitlth
Newbie


Registration Date: 26.04.2007
Posts: 11
Which box: DM 600PVR-S; andere
External Storage: HDD
Which Image: PLi; Sonstige
Welcher Bildschirm: Sharp Aquous 37"
Origin: A

RE: Cable scan problem with the Pcd 3.1 enigma2 image Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

I did not try that before - seemed to be to much work to check all the frequencies manually, and I did not have the important frequencies.

what leads to crash:
- set tuner to any other type of scan than "provider"
- start automatic scan
=> crash

what works:
- set teh tuner to any type of scan
- start manual scan, configure with QAM264 and with frequency 1
- start manual scan, configure with QAM264 and with fequency 2
....
=> all detected stations are in the list, the rest works perfect!

I hope, the description is clear enough.

Thomas
26.11.2010 14:40 taitlth is offline Send an Email to taitlth Search for Posts by taitlth Add taitlth to your Buddy List
Tree Structure | Board Structure
Jump to:
Post New Thread Post Reply
i-have-a-dreambox.com | Dreambox - Support » ...::: Archiv - Support für ältere Dreambox Modelle :::... » ...::: Dreambox und Images DM 600PVR :::... » CVS Images Enigma2 DM600PVR » Cable scan problem with the Pcd 3.1 enigma2 image

Privacy policy | Team | Suchen | Hilfe


Powered by Burning Board 2.3.6 © 2001-2003 WoltLab GbR