i-have-a-dreambox.com | Dreambox - Support

Register Calendar Members List Team Members Galerie to Portal Go to the Main Page

Boardrules Frequently Asked Questions Statistik Statistik Search Pinwand Dreambox Blog Ihad/Gemini Fan-Shop
i-have-a-dreambox.com | Dreambox - Support » ...::: Dreambox Software :::... » Software allgemein » NFS Fehler in 1.6er Versionen? » Hello Guest [Login|Register]
Last Post | First Unread Post Print Page | Add Thread to Favorites
Post New Thread Post Reply
Go to the bottom of this page NFS Fehler in 1.6er Versionen?
Author
Post « Previous Thread | Next Thread »
FNBalu
User


Registration Date: 12.10.2009
Posts: 180
Which box: keine
External Storage: keine
Which Image: Sonstige

NFS Fehler in 1.6er Versionen? Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hallo zusammen.

Ich habe das neueste oozoon 3.1.0 (1.6)auf meinen Boxen und habe da eine NFS Freigabe erstellt bzw versucht.

In der exports steht /media/hdd *(rw,no_root_squash,async,no_subtree_check)

Somit sollte die Freigabe ja für alle funktionieren.
Mit exportfs -a -r ist es aktiviert usw.


Beim client habe ich normal mount probiert mit

mount 192.168.1.33:/media/hdd /media/hdd

Somit sollte er die Freigabe auf den seben Pfad der eigenen Box mounten (es wird eine Platte für 2 Boxen benutzt)

Bei der 2. Box kommt dann imme rnur Permission denied und es lässt sich nichts dran rütteln.


Hat da einer ein Heilmittel oder ne Idee woran das liegen kann?
Das kann doch eigentlich nicht so schwer sein.
Habe da jetzt zig Stunden rum geeiert.
24.04.2011 22:25 FNBalu is offline Send an Email to FNBalu Search for Posts by FNBalu Add FNBalu to your Buddy List Add FNBalu to your Contact List
netman
V.I.P.


images/avatars/avatar-18833.jpeg

Registration Date: 27.04.2007
Posts: 26,984
Which box: DM500HD; DM800; DM900; DM7020HD; DM7025; DM7080HD; DM8000; Goliath
External Storage: NAS
Which Image: Gemini

RE: NFS Fehler in 1.6er Versionen? Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hast du die Serverbox auch schon mal komplett neugestartet.
24.04.2011 22:26 netman is offline Send an Email to netman Search for Posts by netman Add netman to your Buddy List
dIGIMAN/TRSI
Newbie


Registration Date: 05.01.2009
Posts: 49
Which box: DM 800se PVR-C
External Storage: HDD; CF
Which Image: Sonstige

RE: NFS Fehler in 1.6er Versionen? Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

NFS geht bei mir ab oe 1.6 auch nicht mehr, aeussert sich aber anders:

NFS Mount Problem ab OE1.6? Workaround?

Als workarround habe ich erstmal ftpfs laufen, in der Hoffnung das es irgendwann wieder geht...
24.04.2011 22:58 dIGIMAN/TRSI is offline Send an Email to dIGIMAN/TRSI Search for Posts by dIGIMAN/TRSI Add dIGIMAN/TRSI to your Buddy List
EgLe EgLe is a male
V.I.P.*


images/avatars/avatar-10228.gif

Registration Date: 01.10.2004
Posts: 7,389
Which box: DM820; DM7020HD; DM7080HD
External Storage: USB-Stick; HDD; SSD; NAS
Which Image: DMM original
Origin: Baden-Württemberg

RE: NFS Fehler in 1.6er Versionen? Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hallo,

Hmm, also ich habe mit OE 1.6 keine Probleme mit NFS.
Liegt definitiv an falschen Einstellungen und vorgehen Augenzwinkern

Die erste Frage die ich immer stelle....

Habt ihr ein Showmount auf euere box?

http://wiki.blue-panel.com/index.php/Lin...Freigegeben_ist

Ich habe und verwende kein Ozzon, bei einem DMM-Image welches als NFS-Server eingerichtet wurde
ist dies jedenfalls dabei Augenzwinkern

code:
1:
2:
3:
root@dm8000:~# showmount -e 192.168.0.6
Export list for 192.168.0.6:
/media/hdd 192.168.0.0/255.255.255.0


Somit sehe ich schon einmal das der Server sauber funktioniert (wie im Wiki beschreiben) Zunge raus

Dann kommt die nächste frage an den Client....

Wie wird die NFS-Verbindung aufgebaut?

per autofs also der auto.network oder der auto.hotplug???

Wenn es per autofs ist, ist es schonmal total bescheuert zu versuchen das ganze nach /media/hdd zu mounten Augen rollen

Dies würde nur gehen wenn man es direkt in der fstab machen wurde was total bescheuert wäre.
Man macht sich per autofs einen Mountpunkt auf z.B. /media/net udn das Unterverzeichnis erstellt
der autofs dann selbst und bei nichtbenutzung wird dieses Verzeichnis auch wieder automatisch ausgehängt bzw. deaktiviert.

Und wenn man per Videotaste direkt darafu zugreifen will, kann man dies im Menü
unter den Aufnhamepfade entweder angeben, oder man drückt ein zweites mal die Videotaste und kann sich dort ein Lesezeichen erstellen zum Autofs (automountpunkt)


Also erstmal checken ob der Server sauber Arbeitet, dann sich an den Client machen...


Und zum clinet steht im Wiki dann auch etliches Augenzwinkern

Attachments:
jpg bild01.jpg (48 KB, 283 downloads)
jpg bild02.jpg (44.03 KB, 277 downloads)


__________________
MfG EgLe Freude

Linux will Benutzer, die Linux wollen. Linux ist nicht Windows

Kernel : 4.19.1-1-MANJARO
GUI : KDE 5.52.0 / Plasma 5.14.3
Machine : Intel NUC8i7HVK
Graphics : Radeon RX Vega M GH
CPU : Intel Core i7-8809G @ 8x 4.2GHz
RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

25.04.2011 00:18 EgLe is offline Send an Email to EgLe Search for Posts by EgLe Add EgLe to your Buddy List View the MSN Profile for EgLe
FNBalu
User


Registration Date: 12.10.2009
Posts: 180
Which box: keine
External Storage: keine
Which Image: Sonstige

Thread Starter Thread Started by FNBalu
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hallo

Das ist ja der Haken.
Wir haben ja geschaut ob der Server richtig arbneitet.

root@dm7025:~# showmount -e 192.168.1.33
Export list for 192.168.1.33:
/media/hdd 192.168.1.34
root@dm7025:~#

Demnach ist es freigegeben für 192.168.1.34 was der Client ist.
Auch ein Sternchen ahtten wir schon was dann ja world bedeutet.
Das war der Versuch um zu sehen ob er überhaupt die Einstellungen übernimmt.

Selbst Clientseitig sieht das nicht anders aus.
root@dm7025_matze_2:~# showmount -e 192.168.1.33
Export list for 192.168.1.33:
/media/hdd 192.168.1.34

Heisst offiziell ist die Freigabe da.
Wir haben sie versucht nach test zu mounten bzw hddd (3d) usw.
Es geht einfach nicht.

root@dm7025_matze_2:~# mount -t nfs 192.168.1.33:/media/hdd /media/hddd
mount: 192.168.1.33:/media/hdd failed, reason given by server: Permission denied
root@dm7025_matze_2:~#

Der Befehl ist erstmal nur solange bis es funktioniert. Danach kann man ihn immer noch einpflegen.


Da das die 2 Boxen meines Vaters sind, (Hauptbox mit Platte und Clientbox ohne Platte welche die erste nutzen soll) habe ich mal zu meiner verbunden, wo ich gleiches Szenario habe mit 2 Boxen.

Der selbe mountbefehl nur mit der IP meiner Hauptbox geht durch.
root@dm7025_matze_2:~# mount -t nfs 192.168.1.30:/media/hdd /media/hddd
root@dm7025_matze_2:~#

Somit kann die Cleintbox meines Vaters meine Clientbox mounten.
Im Umkehrschluss kann meine Zweitbox nicht die Hauptbox meines Vaters mounten.
root@dm7025:~# mount -t nfs 192.168.1.33:/media/hdd /media/hddd
mount: 192.168.1.33:/media/hdd failed, reason given by server: Permission denied
root@dm7025:~#


IP Übersicht
192.168.1.30 Meine Hauptbox
192.168.1.31 Meine Clientbox
192.168.1.33 Vaters Hauptbox
192.168.1.34 Vaters Clientbox


Aus dem Grunde das Vaters Clientbox meine Hauptbox mounten kann, meine Clientbox aber nicht Vaters Hauptbox, habe ich bzw haben wir den Fehler mehr bei der Hauptbox meines Vaters gesucht.
Irgendwas muss da noch quer schiessen.
Rechtevergabe von /media/hdd??
Oder der exportfs was ja eigentlich Jacke wie Hose sein sollte?

Irgendwie muss das doch gehen.
CIFS ist bei ner grossen Platte keine Alternative, da es irgendwann nichts mehr anzeigt wenn es zu viele Dateien werden.
25.04.2011 05:11 FNBalu is offline Send an Email to FNBalu Search for Posts by FNBalu Add FNBalu to your Buddy List Add FNBalu to your Contact List
dIGIMAN/TRSI
Newbie


Registration Date: 05.01.2009
Posts: 49
Which box: DM 800se PVR-C
External Storage: HDD; CF
Which Image: Sonstige

RE: NFS Fehler in 1.6er Versionen? Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

quote:
Originally posted by EgLe
Hallo,

Hmm, also ich habe mit OE 1.6 keine Probleme mit NFS.
Liegt definitiv an falschen Einstellungen und vorgehen Augenzwinkern


So einfach ist das nicht.
Beim Orginalposter hoert es sich auf dem ersten Blick so an, durch die Meldung aber
vieleicht ist auch hier ein Unterschied.
Es gibt einen Unterschied. Identische Einstellungen. OE1.5 geht, OE1.6 geht nicht mehr,
bei mir.
Aber gut, das ist dann zu weit OT.

@FNBalu:
Vielleicht hilft di ja ftpfs...
25.04.2011 11:06 dIGIMAN/TRSI is offline Send an Email to dIGIMAN/TRSI Search for Posts by dIGIMAN/TRSI Add dIGIMAN/TRSI to your Buddy List
FNBalu
User


Registration Date: 12.10.2009
Posts: 180
Which box: keine
External Storage: keine
Which Image: Sonstige

Thread Starter Thread Started by FNBalu
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Hallo noch mal

Habe gerade nach ftpfs gesucht.
Das Problem ist, dass dieses ja erst cached und dann abspielt.
Da ich aber nur in der Hauptbox die Platte habe und die Zweitbox darauf bei Bedarf aufnehmen soll bzw man dort die aufgenommenen Sachen ansieht, ist das leider nichts ;-(

Mir fällt gerade auf, dass die 8000er von mir (192.168.1.30) noch ein älteres oozoon mit 1.5 installiert hat.

Das kanns doch nicht sein, das nfs mit ner neuen Version gar nicht mehr will oder?
Oder hat sich wa sgeändert? Firewall etc?


@Egle magste mir mal den kompletten inhalt Deiner exports mitteilen?
Sind ja nur IPs drin und sollte einer Veröffentlichung ja nichts entgegensprechen.

This post has been edited 1 time(s), it was last edited by FNBalu: 25.04.2011 18:38.

25.04.2011 18:35 FNBalu is offline Send an Email to FNBalu Search for Posts by FNBalu Add FNBalu to your Buddy List Add FNBalu to your Contact List
Homey[GER] Homey[GER] is a male
Dreambox Gott


images/avatars/avatar-17254.png

Registration Date: 12.02.2006
Posts: 6,960
Which box: DM7020HD; ONE UltraHD
External Storage: NAS
Which Image: DMM original

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

also ich hab hier auch keine probleme unter OE 1.6.

Die exports auf meiner dm7025 (server) sieht so aus:
code:
1:
/media/hdd 192.168.178.25(rw,no_root_squash,async)


Und mounten tue ich auf der dm800 (client) so:
code:
1:
mount -t nfs 192.168.178.20:/media/hdd /media/hdd -o rw,noatime,nolock,intr,soft,udp,rsize=8192,wsize=8192


Klappt wunderbar, auch als noch OE 1.5 auf der DM7025 lief und die DM800 schon ewig mit OE 1.6 lief.
25.04.2011 18:45 Homey[GER] is offline Search for Posts by Homey[GER] Add Homey[GER] to your Buddy List
FNBalu
User


Registration Date: 12.10.2009
Posts: 180
Which box: keine
External Storage: keine
Which Image: Sonstige

Thread Starter Thread Started by FNBalu
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Habe hier noch ne 7025er rumfliegen, die nicht in Benutzung ist, die nutze ich jetzt zum testen.


Dazuhabe ich das genauso wie Du es hast übernommen, nur mit meinen IPs.

Die Clientbox sagt Permission Denied

Ob das an oozoon liegt?
Da ich ja jetzt ne Testbox habe, welche ich zerwurschteln kann wie ich will, knalle ich da gleich mal testweise gemini drauf.
25.04.2011 19:07 FNBalu is offline Send an Email to FNBalu Search for Posts by FNBalu Add FNBalu to your Buddy List Add FNBalu to your Contact List
FNBalu
User


Registration Date: 12.10.2009
Posts: 180
Which box: keine
External Storage: keine
Which Image: Sonstige

Thread Starter Thread Started by FNBalu
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Habe hier noch ne 7025er rumfliegen, die nicht in Benutzung ist, die nutze ich jetzt zum testen.


Dazuhabe ich das genauso wie Du es hast übernommen, nur mit meinen IPs.

Die Clientbox sagt Permission Denied

Ob das an oozoon liegt?
Da ich ja jetzt ne Testbox habe, welche ich zerwurschteln kann wie ich will, knalle ich da gleich mal testweise gemini drauf.
Das hast Du doch Homey, oder?
25.04.2011 19:08 FNBalu is offline Send an Email to FNBalu Search for Posts by FNBalu Add FNBalu to your Buddy List Add FNBalu to your Contact List
OoZooN OoZooN is a male
Dreambox Gott


images/avatars/avatar-2120.gif

Registration Date: 05.03.2005
Posts: 6,675
External Storage: USB-Stick
Which Image: eigenes Image
Welcher Bildschirm: Samsung UE-40B6000V
Origin: Universum-Mitte-Wien hausen

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

also in meinen release images werkelt der selbe nfs server wie in den experimentals und bei mir geht das problemlos. hast du mal versucht, mit dem netzwerkbrowser den mount zu erstellen. ich greife seit ich die 500hd seit anfang letzten jahres habe, per nfs auf die 8000er hdd zu und habe keine probleme.

__________________
mfg

OoZooN

.................................................................

Two Beer or not two Beer, that's the Question

aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter
25.04.2011 22:02 OoZooN is offline Send an Email to OoZooN Homepage of OoZooN Search for Posts by OoZooN Add OoZooN to your Buddy List
FNBalu
User


Registration Date: 12.10.2009
Posts: 180
Which box: keine
External Storage: keine
Which Image: Sonstige

Thread Starter Thread Started by FNBalu
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Ja habe ich. Sogar Vorzugsweise, aber auch keine Erfolge :-(

Deshalb probierte ich es ja manuell.

Habe mal testweise icvs in den Flash gekloppt und da geht es auf anhieb.
Irgendwie gefällt mir aber oozoon besser...
25.04.2011 22:14 FNBalu is offline Send an Email to FNBalu Search for Posts by FNBalu Add FNBalu to your Buddy List Add FNBalu to your Contact List
OoZooN OoZooN is a male
Dreambox Gott


images/avatars/avatar-2120.gif

Registration Date: 05.03.2005
Posts: 6,675
External Storage: USB-Stick
Which Image: eigenes Image
Welcher Bildschirm: Samsung UE-40B6000V
Origin: Universum-Mitte-Wien hausen

Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

tja, hier geht's und ich verwende auch nur das, was auf dem feed liegt.

__________________
mfg

OoZooN

.................................................................

Two Beer or not two Beer, that's the Question

aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter
25.04.2011 22:21 OoZooN is offline Send an Email to OoZooN Homepage of OoZooN Search for Posts by OoZooN Add OoZooN to your Buddy List
FNBalu
User


Registration Date: 12.10.2009
Posts: 180
Which box: keine
External Storage: keine
Which Image: Sonstige

Thread Starter Thread Started by FNBalu
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

Nur wieso gehts hier nicht?
Ist nackig geflasht gewesen.
25.04.2011 22:52 FNBalu is offline Send an Email to FNBalu Search for Posts by FNBalu Add FNBalu to your Buddy List Add FNBalu to your Contact List
FNBalu
User


Registration Date: 12.10.2009
Posts: 180
Which box: keine
External Storage: keine
Which Image: Sonstige

Thread Starter Thread Started by FNBalu
Reply to this Post Post Reply with Quote Edit/Delete Posts Report Post to a Moderator       Go to the top of this page

So habe mal testweise gemini im icvs laufen lassen.
Dort genauso wie bei oozoon über die Erweiterung NFS-Server nachinstalliert und neugestertet.

Da die exports nicht vorhanden war, ahbe ich mit vi exports fix eine erstellt und ganz simpel alles eingetragen.
was soll ich sagen es geht. Die Oozoon Clientbox kann mounten.

Also muss doch irgendwie da der Hase im Pfeffer liegen.
Mich wunderts, dass es bei Dir so problemlos will.
26.04.2011 17:47 FNBalu is offline Send an Email to FNBalu Search for Posts by FNBalu Add FNBalu to your Buddy List Add FNBalu to your Contact List
Tree Structure | Board Structure
Jump to:
Post New Thread Post Reply
i-have-a-dreambox.com | Dreambox - Support » ...::: Dreambox Software :::... » Software allgemein » NFS Fehler in 1.6er Versionen?

Privacy policy | Team | Suchen | Hilfe


Powered by Burning Board 2.3.6 © 2001-2003 WoltLab GbR